Project

General

Profile

Actions

Bug #12221

closed

When upgrading ro Rudder 4.3 (on centos 7), libdb is upgraded, even if we don't use it anymore

Added by Nicolas CHARLES almost 6 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

At upgrade from 4.2 to 4.3, upgrade states

===========================================================================================================================================================================
 Package                                         Architecture              Version                                                        Dépôt                      Taille
===========================================================================================================================================================================
Mise à jour :
 ncf                                             noarch                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                     1.4 M
 ncf-api-virtualenv                              noarch                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                     3.8 M
 rudder-agent                                    x86_64                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                      12 M
 rudder-inventory-endpoint                       noarch                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                      37 M
 rudder-inventory-ldap                           x86_64                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                     1.8 M
 rudder-jetty                                    noarch                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                     7.6 M
 rudder-reports                                  noarch                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                      12 k
 rudder-server-relay                             x86_64                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                     4.2 M
 rudder-server-root                              noarch                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                     8.3 k
 rudder-techniques                               noarch                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                      18 M
 rudder-webapp                                   noarch                    1398866025:4.3.0.rc2.git201803150215-1.EL.7                    Rudder                      91 M
Installation pour dépendances :
 gdbm-devel                                      x86_64                    1.10-8.el7                                                     base                        47 k
 glibc-devel                                     x86_64                    2.17-196.el7_4.2                                               updates                    1.1 M
 glibc-headers                                   x86_64                    2.17-196.el7_4.2                                               updates                    676 k
 kernel-headers                                  x86_64                    3.10.0-693.21.1.el7                                            updates                    6.0 M
 libdb-devel                                     x86_64                    5.3.21-21.el7_4                                                updates                     38 k
 perl-Digest                                     noarch                    1.17-245.el7                                                   base                        23 k
 perl-ExtUtils-Install                           noarch                    1.58-292.el7                                                   base                        74 k
 perl-ExtUtils-MakeMaker                         noarch                    6.68-3.el7                                                     base                       275 k
 perl-ExtUtils-Manifest                          noarch                    1.61-244.el7                                                   base                        31 k
 perl-ExtUtils-ParseXS                           noarch                    1:3.18-3.el7                                                   base                        77 k
 perl-IPC-Cmd                                    noarch                    1:0.80-4.el7                                                   base                        34 k
 perl-Locale-Maketext                            noarch                    1.23-3.el7                                                     base                        93 k
 perl-Locale-Maketext-Simple                     noarch                    1:0.21-292.el7                                                 base                        50 k
 perl-Module-CoreList                            noarch                    1:2.76.02-292.el7                                              base                        85 k
 perl-Module-Load                                noarch                    1:0.24-3.el7                                                   base                        11 k
 perl-Module-Load-Conditional                    noarch                    0.54-3.el7                                                     base                        18 k
 perl-Module-Metadata                            noarch                    1.000018-2.el7                                                 base                        26 k
 perl-Params-Check                               noarch                    1:0.38-2.el7                                                   base                        18 k
 perl-Test-Harness                               noarch                    3.28-3.el7                                                     base                       302 k
 perl-devel                                      x86_64                    4:5.16.3-292.el7                                               base                       453 k
 perl-version                                    x86_64                    3:0.99.07-2.el7                                                base                        84 k
 pyparsing                                       noarch                    1.5.6-9.el7                                                    base                        94 k
 systemtap-sdt-devel                             x86_64                    3.1-5.el7_4                                                    updates                     71 k
Mise à jour pour dépendances :
 libdb                                           x86_64                    5.3.21-21.el7_4                                                updates                    719 k
 libdb-utils                                     x86_64                    5.3.21-21.el7_4                                                updates                    132 k


libdb isn't used anymore, so we shan't upgrade it


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #12184: Wrong dependencies in agent rpm in 4.3ReleasedBenoît PECCATTEActions
Actions #1

Updated by François ARMAND almost 6 years ago

  • Translation missing: en.field_tag_list set to Blocking 4.3
Actions #2

Updated by Benoît PECCATTE almost 6 years ago

  • Translation missing: en.field_tag_list deleted (Blocking 4.3)
  • Status changed from New to Rejected

Duplicates #12184

Actions #3

Updated by Benoît PECCATTE almost 6 years ago

  • Is duplicate of Bug #12184: Wrong dependencies in agent rpm in 4.3 added
Actions

Also available in: Atom PDF