Project

General

Profile

Bug #16244

sudoManagement on SLES15 not working

Added by Florian Heigl 9 months ago. Updated 9 months ago.

Status:
Rejected
Priority:
N/A
Category:
Techniques
Target version:
Pull Request:
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Getting started - demo | first install | Technique editor and level 1 Techniques
Effort required:
Priority:
70

Description

The sudo management classic technique throws an error when used on SLES15.
It tries to autoinstall sudo (which is of course installed as part of the OS) and then ... idk

warning sudoParameters None sudo If you tried to install a virtual package, please use in place the concrete package you want to install.
E| error sudoParameters Install sudo Installing package sudo could not be repaired
E| error sudoParameters Install sudo Installing package sudo could not be repaired

debug foo:

opensuse-leap-x64:/var/rudder/tmp # sudo
usage: sudo -h | -K | -k | -V
usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user] [command]
usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u user] [VAR=value] [-i|-s] [<command>]
usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u user] file ...
opensuse-leap-x64:/var/rudder/tmp # rpm -aq | grep sudo
sudo-1.8.22-lp150.8.1.x86_64
yast2-sudo-4.0.0-lp150.2.3.1.noarch

The edits to /etc/sudoers work correctly, but seem to not be reported in this case.


Related issues

Related to ncf - Bug #16247: Package state SLES15 no workyRejectedActions
Is duplicate of Rudder - User story #16249: OpenSUSE should be detected as "suse" os familyReleasedNicolas CHARLESActions
#1

Updated by Fran├žois ARMAND 9 months ago

  • Target version set to 5.0.15
  • Severity changed from Minor - inconvenience | misleading | easy workaround to Major - prevents use of part of Rudder | no simple workaround
  • Priority changed from 50 to 70

Thanks for reporting.

#2

Updated by Alexis MOUSSET 9 months ago

  • Assignee set to Alexis MOUSSET
#3

Updated by Alexis MOUSSET 9 months ago

Could not reproduce for now (on 6.0):

   info          sudoParameters            None                      sudo               Presence of package sudo in any version was correct
E| compliant     sudoParameters            Install sudo                                 Installing package sudo was correct

This may be a problem with the zypper package module.

#4

Updated by Alexis MOUSSET 9 months ago

Could you give the output of rudder agent info -v to see system classes? Leap may not be detected correctly.

#5

Updated by Alexis MOUSSET 9 months ago

  • Related to Bug #16247: Package state SLES15 no worky added
#6

Updated by Florian Heigl 9 months ago

Hi Alexis,
here's the output.
So, it says leap15 not sles15, guess you're on to the right thing.
One sideproject I got is to fix packer builds for this, once done you'll be able to use them, if needed.

Removed a few ip/net related things, rest unmodified

Hostname: opensuse-leap-x64.ZZZ.deepthink.ag
UUID: 850436a4-52a1-4bbe-96ad-b1bba163c8de
Key hash: MD5=e85cd43e534a6b361d29ebf6eb7dc731
Certificate creation: Nov 21 21:33:44 2019 GMT
Certificate expiration: Nov 18 21:33:44 2029 GMT
Certificate fingerprint: 90:5F:E5:BE:E9:BD:6B:04:C5:26:24:16:FF:41:6F:58:B9:AD:E7:A4
Certificate:
-----BEGIN CERTIFICATE-----
b zzzzzzzz
-----END CERTIFICATE-----
Policy server: ZZZZZZZ
Roles: rudder-agent
Report mode: full-compliance
Run interval: 5 min
Agent is enabled
Agent is not forced in audit mode
Configuration id: 20191121-224512-e221974c
Policy updated: 2019-11-22 08:41:06
Inventory sent: 2019-11-22 04:51:08
Version: Rudder agent 6.0.0.beta1
Defined system conditions:
127_0_0_1
2_cpus
Day22
Friday
GMT_Day22
GMT_Friday
GMT_Hr08
GMT_Hr08_Q3
GMT_Hr8
GMT_Lcycle_0
GMT_Min40_45
GMT_Min41
GMT_Morning
GMT_November
GMT_Q3
GMT_Yr2019
Hr08
Hr08_Q3
Hr8
Lcycle_0
Min40_45
Min41
Morning
November
PK_MD5_e85cd43e534a6b361d29ebf6eb7dc731
Q3
Yr2019
ag
cfengine
cfengine_3
cfengine_3_12
cfengine_3_12_2
community_edition
deepthink_ag
have_aptitude
ipv4_127
ipv4_127_0
ipv4_127_0_0
ipv4_127_0_0_1
ZZZZ_deepthink_ag
linux
linux_4_12_14_lp150_12_82_default
linux_x86_64
linux_x86_64_4_12_14_lp150_12_82_default
linux_x86_64_4_12_14_lp150_12_82_default__1_SMP_Tue_Nov_12_16_32_38_UTC_2019__c939e24_
opensuse
opensuse_leap
opensuse_leap_15
opensuse_leap_15_0
opensuse_leap_x64
opensuse_leap_x64_lZZZZZ_deepthink_ag
rudder_edition
systemd
x86_64

#7

Updated by Alexis MOUSSET 9 months ago

  • Status changed from New to Rejected

Closing, fixed by #16249

#8

Updated by Alexis MOUSSET 9 months ago

  • Is duplicate of User story #16249: OpenSUSE should be detected as "suse" os family added

Also available in: Atom PDF