Project

General

Profile

Actions

Bug #22691

closed

Technique with empty description causes error in webapp log in Rudder 7.3

Added by Nicolas CHARLES 10 months ago. Updated 10 months ago.

Status:
Rejected
Priority:
N/A
Category:
Web - Config management
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
It bothers me each time
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Priority:
44
Name check:
To do
Fix check:
To do
Regression:
No

Description

The error message complains that description is mandatory but is missing (empty):

Consistancy: Description is mandatory but wasn't found for variable spec elt: <INPUT>
        <NAME>D0BD40C2-7270-4B49-BCE3-55F349DC3027</NAME>
        <DESCRIPTION/>
        <LONGDESCRIPTION/>
        <CONSTRAINT>
          <TYPE>textarea</TYPE>
          <MAYBEEMPTY>false</MAYBEEMPTY>
        </CONSTRAINT>
      </INPUT>

[2023-04-26 10:57:48+0200] ERROR techniques.reader - Error with technique at path: '/ncf_techniques/test/1.0/metadata.xml', it will be ignored. Error: Chained: Couldn't parse Section in test/1.0 -> test for XML: <SECTION name="Technique parameters">
      <INPUT>
        <NAME>D0BD40C2-7270-4B49-BCE3-55F349DC3027</NAME>
        <DESCRIPTION/>
        <LONGDESCRIPTION/>
        <CONSTRAINT>
          <TYPE>textarea</TYPE>
          <MAYBEEMPTY>false</MAYBEEMPTY>
        </CONSTRAINT>
      </INPUT>
    </SECTION>; cause was: Chained: In test/1.0 -> test, couldn't parse variable <INPUT>
        <NAME>D0BD40C2-7270-4B49-BCE3-55F349DC3027</NAME>
        <DESCRIPTION/>
        <LONGDESCRIPTION/>
        <CONSTRAINT>
          <TYPE>textarea</TYPE>
          <MAYBEEMPTY>false</MAYBEEMPTY>
        </CONSTRAINT>
      </INPUT>; cause was: Consistancy: Description is mandatory but wasn't found for variable spec elt: <INPUT>
        <NAME>D0BD40C2-7270-4B49-BCE3-55F349DC3027</NAME>
        <DESCRIPTION/>
        <LONGDESCRIPTION/>
        <CONSTRAINT>
          <TYPE>textarea</TYPE>
          <MAYBEEMPTY>false</MAYBEEMPTY>
        </CONSTRAINT>
      </INPUT>
[2023-04-26 10:57:48+0200] ERROR techniques.reader - Error with technique at path: '/ncf_techniques/test/1.0/metadata.xml', it will be ignored. Error: Chained: Couldn't parse Section in test/1.0 -> test for XML: <SECTION name="Technique parameters">
      <INPUT>
        <NAME>D0BD40C2-7270-4B49-BCE3-55F349DC3027</NAME>
        <DESCRIPTION/>
        <LONGDESCRIPTION/>
        <CONSTRAINT>
          <TYPE>textarea</TYPE>
          <MAYBEEMPTY>false</MAYBEEMPTY>
        </CONSTRAINT>
      </INPUT>
    </SECTION>; cause was: Chained: In test/1.0 -> test, couldn't parse variable <INPUT>
        <NAME>D0BD40C2-7270-4B49-BCE3-55F349DC3027</NAME>
        <DESCRIPTION/>
        <LONGDESCRIPTION/>
       <CONSTRAINT>
          <TYPE>textarea</TYPE>
          <MAYBEEMPTY>false</MAYBEEMPTY>
        </CONSTRAINT>
      </INPUT>; cause was: Consistancy: Description is mandatory but wasn't found for variable spec elt: <INPUT>
        <NAME>D0BD40C2-7270-4B49-BCE3-55F349DC3027</NAME>
        <DESCRIPTION/>
        <LONGDESCRIPTION/>
        <CONSTRAINT>
          <TYPE>textarea</TYPE>
          <MAYBEEMPTY>false</MAYBEEMPTY>
        </CONSTRAINT>
      </INPUT>
<pre> 

happens after an upgrade from 7.2

Technique content is
<pre>
{
  "id":"test",
  "version":"1.0",
  "category":"ncf_techniques",
  "description":"",
  "name":"test",
  "calls":[],
  "parameter":[
    {
      "id":"d0bd40c2-7270-4b49-bce3-55f349dc3027",
      "name":"",
      "description":"",
      "mayBeEmpty":false
    }
  ],
  "resources":[],
  "source":"editor" 
}
</pre>
happens after an upgrade
Actions #1

Updated by Vincent MEMBRÉ 10 months ago

  • Target version changed from 7.3.1 to 7.3.2
Actions #2

Updated by François ARMAND 10 months ago

  • Subject changed from empty technique causes error in webapp log in Rudder 7.3 to Technique with empty description causes error in webapp log in Rudder 7.3
  • Description updated (diff)
  • Severity set to Minor - inconvenience | misleading | easy workaround
  • UX impact set to It bothers me each time
  • User visibility set to Operational - other Techniques | Rudder settings | Plugins
  • Priority changed from 0 to 44
Actions #3

Updated by François ARMAND 10 months ago

  • Status changed from New to In progress
  • Assignee set to François ARMAND
Actions #4

Updated by François ARMAND 10 months ago

The backend code for that is the same since at least 4 years, so perhaps something changed in the front?

Actions #5

Updated by François ARMAND 10 months ago

For context: the whole technique is empty, the parameter has no name, it's strange that it is even accepted.

Actions #6

Updated by François ARMAND 10 months ago

  • Status changed from In progress to Rejected

Trying to save a similar technique leads to an error.
I would say something non consistant was done, and rudder complaining is the expected behavior.

I'm closing it but feel free to reopen with more information about why we should do something else.

Actions

Also available in: Atom PDF