Project

General

Profile

Actions

Bug #3432

closed

Duplicate selection of value for variable "execRun" in scope g

Added by Dennis Cabooter about 11 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
4
Category:
System techniques
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Name check:
Fix check:
Regression:

Description

On all nodes I see the following in syslog:

!! Duplicate selection of value for variable "execRun" in scope g
!! Rule from /var/rudder/cfengine-community/inputs/common/1.0/site.cf at/before line 58

I created the following patch to solve this:

--- /var/rudder/cfengine-community/inputs/common/1.0/site.cf.orig    2013-04-12 11:54:44.345172104 +0200
+++ /var/rudder/cfengine-community/inputs/common/1.0/site.cf    2013-04-12 11:55:12.966302242 +0200
@@ -38,7 +38,8 @@
    "escaped_workdir" string => escape("$(sys.workdir)");

    # The time at which the execution started
-   "execRun" string => execresult("\"${g.rudder_sbin}\getDate.bat\"", "noshell");
+   "execRun" string => execresult("\"${g.rudder_sbin}\getDate.bat\"", "noshell"),
+             policy => "overridable";

  windows.!cygwin::
    "uuid_file" string => "${rudder_base}\etc\uuid.hive";
@@ -55,7 +56,8 @@
     "crontab" string => "/etc/crontab";

     # The time at which the execution started
-    "execRun" string => execresult("/bin/date --rfc-3339=second", "noshell");
+    "execRun" string => execresult("/bin/date --rfc-3339=second", "noshell"),
+              policy => "overridable";

  any::
    "uuid" string => readfile("$(g.uuid_file)", 60);
Actions #1

Updated by Nicolas PERRON about 11 years ago

  • Target version changed from 2.5.2 to 2.5.3
Actions #2

Updated by Nicolas CHARLES about 11 years ago

  • Category set to System techniques
  • Assignee set to Matthieu CERDA
  • Target version changed from 2.5.3 to 2.3.12

Matthieu,

could you apply the modifications ?
Thanks

Actions #3

Updated by Nicolas CHARLES about 11 years ago

  • Status changed from New to 8
  • Priority changed from N/A to 4
Actions #4

Updated by Jonathan CLARKE about 11 years ago

  • Status changed from 8 to Discussion
  • Assignee changed from Matthieu CERDA to Dennis Cabooter

I just tested this, and I have noticed that these warning messages only appear if running cf-agent with the "-I" option.

Unfortunately, the workaround above does not fix this. That is, running cf-agent with -I, I still get the warning messages, even with "policy => overridable". I also never see this in syslog output, only in the interactive agent output.

Dennis, are you sure you saw this in syslog?

Actions #5

Updated by Dennis Cabooter about 11 years ago

As far as I can remember I only see the warnings if I perform a "/var/rudder/cfengine-community/bin/cf-agent -KI". On my system the warning disappeared after adding "policy => overridable".

Actions #6

Updated by Jonathan CLARKE about 11 years ago

Dennis Cabooter wrote:

As far as I can remember I only see the warnings if I perform a "/var/rudder/cfengine-community/bin/cf-agent -KI". On my system the warning disappeared after adding "policy => overridable".

Right, so it is indeed linked to the "-I" option of cf-agent.

However, I cannot reproduce this fix. When I add policy => overridable, I still get the error messages :-(

Actions #7

Updated by Matthieu CERDA about 11 years ago

  • Target version changed from 2.3.12 to 2.3.13
Actions #8

Updated by Nicolas PERRON about 11 years ago

  • Target version changed from 2.3.13 to 84
Actions #9

Updated by Nicolas PERRON about 11 years ago

  • Target version changed from 84 to 2.4.7
Actions #10

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 2.4.7 to 2.4.8
Actions #11

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 2.4.8 to 2.4.9
Actions #12

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.9 to 2.4.10
Actions #13

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.10 to 2.4.11
Actions #14

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.11 to 2.4.12
Actions #15

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.12 to 2.4.13
Actions #16

Updated by Vincent MEMBRÉ over 10 years ago

  • Target version changed from 2.4.13 to 2.6.11

Since 2.4 is not maintained anymore, retargeting to branch 2.6

Actions #17

Updated by Nicolas CHARLES over 10 years ago

  • Status changed from Discussion to Rejected

I cannot reproduce it anymore (neither in 2.6 nor 2.8)
Fixed by http://www.rudder-project.org/redmine/issues/3454

So, I'm closing this ticket.
Dennis, if you still have the issue, please feel free to reopen it and tell me I'm wrong.
Thank you

Actions

Also available in: Atom PDF