Project

General

Profile

Actions

User story #3804

closed

Disable many rules at the same time

Added by Cedric JARDIN almost 11 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Config management
UX impact:
Suggestion strength:
User visibility:
Effort required:
Name check:
Fix check:
Regression:

Description

Hello,

Is that possible to disable many rules at the same time ?

A sort of clickable box to select many rules before to disable them.

BR


Related issues 1 (1 open0 closed)

Is duplicate of Rudder - User story #6269: Proposal: have the possibility to mass delete/disable rules/directivesNewActions
Actions #1

Updated by Nicolas CHARLES almost 11 years ago

  • Project changed from 24 to Rudder

Hi Cedric,

It's currently not possible to disable several rules at the same time.
What would be your use case for this ?

Actions #2

Updated by Vincent MEMBRÉ almost 11 years ago

Hello Cédric,

There is no way to achieve this in Rudder for now (2.6.3).

In 2.7.0 there will be a Rest API. With it you can modify Rules without having to use the webapp. You could create a script that take multiple Rule ids and disable them using the API.

However, we need to improve the webapp, because repeating the same action can be a very long task. You're idea is a good catch to improve Rules. At least you should not have to open the Rule details to disable a Rule.

Thanks for reporting that idea!! Do you have any other use case or any question about that ?

Actions #3

Updated by Jonathan CLARKE almost 11 years ago

  • Tracker changed from Question to User story

This makes a nice "User story" to implement. I can imagine a system where you could select Rules in the list (checkbox in front of each one), then choose a "Apply to all selected" action among "Disable", "Delete", "Edit"...

Actions #4

Updated by Nicolas PERRON almost 11 years ago

  • Target version set to Ideas (not version specific)
Actions #5

Updated by Cedric JARDIN almost 11 years ago

Hello,

Sorry for the latency :)

My main goal is to quickly deploy servers with specifics softs.

Some actions needed to be done just one time and don't have to be replayed after.

It will be great if rules/directives could be selected and applied just one time on one node (for the moment we can't apply rules to a node without putting it on a group)

One other point of view, it will be also great if we could select the order of rules application/deployement.

I hope this functions will be included for the next release :)

Thanks for your support

Actions #6

Updated by Jonathan CLARKE over 10 years ago

  • Category set to Web - Config management
Actions #7

Updated by Alexis Mousset almost 8 years ago

  • Is duplicate of User story #6269: Proposal: have the possibility to mass delete/disable rules/directives added
Actions #8

Updated by Alexis Mousset almost 8 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF