Project

General

Profile

Bug #4123

a2ensite changes its behavior in Debian Jessie

Added by Jean Remond about 7 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
5
Assignee:
Matthieu CERDA
Category:
Packaging
Target version:
-
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

a2ensite needs ".conf" extension to work properly in Debian Jessie
it makes rudder-webapp postinstall script fails when a2ensite tries to activate rudder-vhost

I know Debian Jessie is not yet supported but I hope this information will be helpful for the future.


Related issues

Is duplicate of Rudder - User story #5160: The rudder-webapp virtualhosts for Apache 2.4 need to be named with a .conf suffixReleasedMatthieu CERDA2014-06-26Actions
#1

Updated by Matthieu CERDA about 7 years ago

  • Status changed from New to 8
  • Assignee set to Matthieu CERDA
  • Priority changed from N/A to 5
  • Target version set to 2.8.0

Since Debian Jessie is not even in "freeze" status yet (http://release.debian.org/jessie/freeze_policy.html), this is not a very high priority, however, the fix is quite simple. (Detecting which version on Debian the package is launching its postinstall (using /etc/debian_version) and behaving accordingly.

#2

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 2.8.0 to 2.8.1

This won't be done until 2.8.1

#3

Updated by Nicolas PERRON about 7 years ago

  • Target version changed from 2.8.1 to 2.8.2
#4

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 2.8.2 to 2.8.3
#5

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 2.8.3 to 2.8.4
#6

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 2.8.4 to 133
#7

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 133 to 2.9.5
#8

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.9.5 to 2.9.6
#9

Updated by Jonathan CLARKE over 6 years ago

  • Target version changed from 2.9.6 to 2.9.7
#10

Updated by Jonathan CLARKE over 6 years ago

  • Target version changed from 2.9.7 to 150
#11

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 150 to 2.10.4
#12

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.10.4 to 2.10.5
#13

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.10.5 to 2.10.6
#14

Updated by Matthieu CERDA over 6 years ago

  • Target version changed from 2.10.6 to 2.10.7
#15

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.10.7 to 2.10.8
#16

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.10.8 to 2.10.9
#17

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.10.9 to 2.10.10
#18

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.10.10 to 2.10.11
#19

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.10.11 to 2.10.12
#20

Updated by Benoît PECCATTE almost 6 years ago

  • Project changed from packages to Rudder
  • Category set to Packaging
#21

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.10.12 to 2.10.13
#22

Updated by Benoît PECCATTE almost 6 years ago

  • Status changed from 8 to New
#23

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.10.13 to 2.10.14
#24

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.10.14 to 2.10.15
#25

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.10.15 to 2.10.16
#26

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.10.16 to 2.10.17
#27

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.10.17 to 2.10.18
#28

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.10.18 to 2.10.19
#29

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.19 to 2.10.20
#30

Updated by Matthieu CERDA about 5 years ago

  • Status changed from New to Rejected
  • Target version deleted (2.10.20)
  • % Done changed from 0 to 100

This ticket duplicates #5160 and is now fixed :)

#31

Updated by Matthieu CERDA about 5 years ago

  • Is duplicate of User story #5160: The rudder-webapp virtualhosts for Apache 2.4 need to be named with a .conf suffix added

Also available in: Atom PDF