Project

General

Profile

Actions

Bug #4357

closed

Editing a Directive, after creating/cloning, does not show the workflow popup nor redirect to the change request

Added by Nicolas PERRON about 9 years ago. Updated over 8 years ago.

Status:
Released
Priority:
2
Category:
Web - UI & UX
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

I can't say when it happens exactly (seems to happen randomly) but sometimes the Pending Review page is not displayed after the "Submit Validation" button.
For example it happens after changing just the source file in the "Download From A Shared Folder"./


Files

WrongPopupForChangeRequest.jpg (242 KB) WrongPopupForChangeRequest.jpg Nicolas PERRON, 2014-03-10 15:34

Related issues 1 (0 open1 closed)

Related to Rudder - Bug #4359: It is overly slow to show the list of Pending Review or Pending Deployment even if the number is 0ReleasedFrançois ARMAND2014-01-14Actions
Actions #1

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.6.10 to 2.6.11
Actions #2

Updated by Nicolas PERRON almost 9 years ago

  • Assignee set to Vincent MEMBRÉ

It seems that on Rudder 2.9 it happens when a modification is not made on the "Parameters" tab into a Directive edition.
The 'Save' button is proposed but no modification is made an a "pending review" is added. We are obliged to go through the list of change request which is overly slow (cf #4359)

Actions #3

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.6.11 to 2.6.12
Actions #4

Updated by Vincent MEMBRÉ almost 9 years ago

  • Status changed from New to Discussion
  • Assignee changed from Vincent MEMBRÉ to Nicolas PERRON

I can't reproduce it, on my 2.9.2 server, I try multiples pattern (one from each tab, only one ...) and never got the problem

Is it still happenning ?? no errors in the webapp logs?

Actions #5

Updated by Nicolas PERRON almost 9 years ago

Here is a screenshot of the popup. The button should be "Submtit Validation" but this is "Save"

Actions #6

Updated by Nicolas PERRON almost 9 years ago

I believe that the problem occurs if a Directive has been created of cloned. Until the reload of the Directives screen, no 'Submit Validation' will be available.

Actions #7

Updated by Nicolas PERRON almost 9 years ago

Nicolas PERRON wrote:

I believe that the problem occurs if a Directive has been created of cloned. Until the reload of the Directives screen, no 'Submit Validation' will be available.

It seems to only occurs during this scenario.

Actions #8

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.6.12 to 2.6.13
Actions #9

Updated by Vincent MEMBRÉ almost 9 years ago

  • Status changed from New to In progress
  • Target version changed from 2.6.13 to 2.9.5

This is happenning only in 2.9

Actions #10

Updated by Vincent MEMBRÉ almost 9 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Vincent MEMBRÉ to François ARMAND
  • Pull Request set to https://github.com/Normation/rudder/pull/485
Actions #11

Updated by Vincent MEMBRÉ almost 9 years ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100
Actions #13

Updated by Vincent MEMBRÉ almost 9 years ago

  • Subject changed from Sometimes, during save of a Directive with Workflow enabled, the Pending review screen is not displayed to Editing a Directive, after creating/cloning, does not show the workflow popup nor redirect to the change request
Actions #14

Updated by Vincent MEMBRÉ over 8 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.9.5 (announcement , changelog) and 2.10.1 (announcement , changelog), which were released today.

Actions

Also available in: Atom PDF