Project

General

Profile

Actions

Bug #4657

closed

/var/rudder gets too big on nodes

Added by Dennis Cabooter over 8 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
N/A
Category:
Web - Config management
Target version:
-
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

The title says it all.

This is from only 2 days:

[root@node ~]# du -hs /var/rudder/modified-files/
686M    /var/rudder/modified-files/
[root@node ~]# du -hs /var/rudder/cfengine-community/state/
81M    /var/rudder/cfengine-community/state/
[root@node ~]# du -hs /var/rudder/cfengine-community/outputs/
153M    /var/rudder/cfengine-community/outputs/
[root@node ~]# echo "686+81+153" | bc
920

Related issues 1 (0 open1 closed)

Related to Rudder - Bug #4650: Multiline header is added at each run on managed filesReleasedJonathan CLARKE2014-11-04Actions
Actions #1

Updated by Nicolas CHARLES over 8 years ago

  • Category set to 14
  • Status changed from New to Discussion
  • Assignee set to Dennis Cabooter

Dennis, you will be pleased, in 2.10 the retention is configurable (see http://www.rudder-project.org/redmine/issues/4369 )

Does it correspond to your need ?

Actions #2

Updated by Dennis Cabooter over 8 years ago

I'm not sure which directories will grow over time. But this growth is really from 2 days. I think if /var/rudder grows more than 1G in 2 days, that's a lot! It seems somthing goes wrong somewhere. Also, are all directories growing get configurable in 2.10?

Actions #3

Updated by Vincent MEMBRÉ over 8 years ago

I think the growth rate is mostly due to #4650, some files change every 5 minutes (npt.conf, motd), making them pile up in that directory (and your ntp.conf grows really big ...)

Actions #4

Updated by Dennis Cabooter over 8 years ago

That makes sense. What about the state directory?

Actions #5

Updated by Nicolas CHARLES almost 8 years ago

Dennis,

We made a lot of modification around that, most notably making everything configurable in the UI

Did it fix your issue ?

Actions #6

Updated by Benoît PECCATTE over 7 years ago

  • Category changed from 14 to Web - Config management
Actions #7

Updated by Nicolas CHARLES about 7 years ago

Dennis, we improved a lot of things there (configure retention time), and corrected the everygrowing of file. Did this fix your issue ? Without answer from you, we'll assume it is now fixed, and close the ticket

Thanks!

Actions #8

Updated by Benoît PECCATTE over 5 years ago

  • Related to Bug #4650: Multiline header is added at each run on managed files added
Actions #9

Updated by Benoît PECCATTE over 5 years ago

  • Status changed from Discussion to Rejected

The bvug seems to be fixed in #4650 and the reporter doesn't answer anymore

Actions

Also available in: Atom PDF