Project

General

Profile

Bug #4716

Promises generation fails on relay server

Added by Anonymous over 6 years ago. Updated about 6 years ago.

Status:
Released
Priority:
1
Category:
Server components
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

Hello,

On 2.9.4 version of Rudder (in target version , we don't have the choice of 2.9.4)

I have 1 network with 1 server and 1 relay interface , and an other network with 1 relay interface and 1 node.

[Server<->Relay<->Node]
First network : 1.0.0.0/8
Second network : 2.0.0.0/8

The relay and the node are accept on server.
The script node-to-relay worked very well.
The node have the relay name in policy-server.dat .
When i have accepted the node on server, the regeneration of rules failed with errors :

ERROR com.normation.rudder.services.policies.RudderCf3PromisesFileWriterServiceImpl - Could not find freshly created promises at /var/rudder/share/bb8ee6c0-0dff-4f82-a2fc-efffc0c45853.new/share/7e9a3418-6432-45d9-8924-71b5690b9db0.new

ERROR com.normation.rudder.services.policies.RudderCf3PromisesFileWriterServiceImpl - Could not write promises into /var/rudder/share/bb8ee6c0-0dff-4f82-a2fc-efffc0c45853.new/share/7e9a3418-6432-45d9-8924-71b5690b9db0, reason :
java.io.IOException: Created promises not found !!!! at .....

The cf-agent -KI on relay return "error : During agent identification for '1.0.0.2'" ( IP of server side relay interface ).
Same error on node ( with ip 2.0.0.2) . All IPs and name are in /etc/hosts of all system .

curl http://nameofrelay/uuid ( on the node ) return the uuid of relay.

How i can resolv that ?

Thanks !


Files

details.png (17.6 KB) details.png screenshot Anonymous, 2014-04-01 10:14
INFO_2014_04_01.stderrout.log (3.21 KB) INFO_2014_04_01.stderrout.log Info loglevel Anonymous, 2014-04-01 10:14
DEBUG_2014_04_01.stderrout.log (74.4 KB) DEBUG_2014_04_01.stderrout.log Debug loglevel Anonymous, 2014-04-01 10:14
#1

Updated by Vincent MEMBRÉ over 6 years ago

  • Subject changed from Regeneration fail and error during agent identification to Promises generation fails on relay server
  • Category set to Server components
  • Status changed from New to Discussion
  • Assignee set to Anonymous
  • Priority changed from N/A to 1
  • Target version set to 2.9.5

Thank You Mikaël for reporting!

Can you provide the full error message you get? (after : java.io.IOException: Created promises not found !!!! at ...)
Can you provide a screenshot of what you see in the error popup (provided by clicking on 'details' in the top right corner in the UI )

Can you provide an extract of logs from /var/log/rudder/webapp/2014_03_31.stderrout.log ? both in info level and debug level ( modify loglevel from /opt/rudder/etc/logback.xml loglevel should be info, change it to debug)

Thank you a lot!

#2

Updated by Anonymous over 6 years ago

Thank you for response.

I give you logs in INFO and DEBUG loglevel, and the screenshot of the error popup.

The full error message (afetr : java.io.IO .... ) is in logs in INFO loglevel.

Thank you for your time.

#3

Updated by Nicolas CHARLES over 6 years ago

  • Assignee changed from Anonymous to Nicolas CHARLES

Ok, I see the problem; somehow the promises of the relay (and promises of its children) are moved before those of the children, hence making them unavailable

#4

Updated by Nicolas CHARLES over 6 years ago

  • Status changed from Discussion to In progress
#5

Updated by Nicolas CHARLES over 6 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Nicolas CHARLES to François ARMAND
  • Pull Request set to https://github.com/Normation/cf-clerk/pull/38
#6

Updated by Nicolas CHARLES over 6 years ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100

Applied in changeset clerk:commit:3bd77addbf016596f84647c78e13d18e5e2c5302.

#7

Updated by François ARMAND over 6 years ago

Applied in changeset clerk:commit:e2df73e695d509fed62356cd2664bc51505328a2.

#8

Updated by Anonymous about 6 years ago

Thanks !

I have upgrade the server in 2.10 and 2.10 nightly , and the generation works fine but i have errors when i launch cf-agent -KI on the node :

http://pastebin.com/jvJ9Ech0

Why i have these errors ?

#9

Updated by Vincent MEMBRÉ about 6 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.9.5 (announcement , changelog) and 2.10.1 (announcement , changelog), which were released today.

Also available in: Atom PDF