Project

General

Profile

Actions

User story #7251

closed

Management of shared-files

Added by Marc Weistroff over 8 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Config management
UX impact:
Suggestion strength:
User visibility:
Effort required:
Name check:
Fix check:
Regression:

Description

As a rudder user, I would like to be able to browse/upload/edit/manage files that are in the `/var/rudder/configuration-repository/shared-files` folder.

Each time a change is made in the directory or to a file, I would like the change to be committed in the underlying git repository.


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - User story #9211: Add Directive field with a graphical File Explorer for shared files ReleasedVincent MEMBRÉ2016-10-05Actions
Actions #1

Updated by Olivier Mauras over 8 years ago

No thanks I'm fine the way it is.
The implementation of this kind of feature should not disrupt the underlying workflow that some users have already implemented.

Actions #2

Updated by Benoît PECCATTE over 8 years ago

We could do it for a specific sub directory of shared-files

Actions #3

Updated by Olivier Mauras over 8 years ago

I'd prefer an option to NOT have the feature at all

Actions #4

Updated by Dennis Cabooter over 8 years ago

@Marc: +1
@Olivier: You can keep your workflow and we could be able to do it in the GUI
@Benoît: You should implement it for the whole directory /var/rudder/configuration-repository/shared-files and then create a button to commit, so people can choose whether it'll be commited or not

Actions #5

Updated by Dennis Cabooter over 8 years ago

My point is... having a GUI to do everything and then still having do some things out of the GUI, like adding a rudder-user or edit a shared
file, feels a bit silly. I'd prefer to keep my focus in one place. Just my 2 cents...

Actions #6

Updated by Vincent MEMBRÉ over 8 years ago

  • Category set to Web - Config management
  • Target version set to Ideas (not version specific)

Thanks Marc for your proposal !

I think this is a good idea to add the possibility to manage shared files via a GUI

I clearly agree with Olivier that it should not change how people manage their shared file and interfere with their current workflow

Actions #7

Updated by Benoît PECCATTE almost 7 years ago

  • Is duplicate of User story #9211: Add Directive field with a graphical File Explorer for shared files added
Actions #8

Updated by Benoît PECCATTE almost 7 years ago

  • Status changed from New to Rejected

Done in #9211

Actions

Also available in: Atom PDF