Project

General

Profile

Actions

Bug #10423

closed

Missing "update" reports on Relay in rare cases

Added by Nicolas CHARLES about 7 years ago. Updated 10 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
System techniques
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Priority:
0
Name check:
Fix check:
Regression:
No

Description

The "update" report for relay is missing for the run following and update when ncf technique are updated at the same time that promises


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #12137: Missing "update" reports on nodeReleasedNicolas CHARLESActions
Actions #1

Updated by Nicolas CHARLES about 7 years ago

  • Subject changed from Random missing "update" reports on policy server to missing "update" reports on Relay
  • Description updated (diff)
Actions #2

Updated by Nicolas CHARLES about 7 years ago

ok, i tried to figure out with dumpdatastate why it was so, without any success
I have the following classes set

    "rudder_ncf_common_updated_ok": true,
    "rudder_ncf_hash_update_ok": true,
    "rudder_ncf_hash_update_repaired": true,
    "rudder_ncf_local_updated_ok": true,
    "rudder_promises_generated_ok": true,
    "policy_server": true,

which match the condition
    ((root_server.rudder_ncf_common_updated_ok.rudder_ncf_local_updated_ok)|(!root_server.(rudder_ncf_hash_update_ok|(rudder_ncf_hash_update_repaired.rudder_ncf_common_updated_ok.rudder_ncf_local_updated_ok)))).(policy_server|rudder_tools_updated_kept|(rudder_tools_updated_repaired.rudder_tools_updated_ok)).(root_server|rudder_promises_generated_ok|(rudder_promises_generated_repaired.config_ok)).!(rudder_promises_generated_repaired|rudder_promises_generated_error|rudder_tools_updated_error|rudder_tools_updated|rudder_tools_update_error|rudder_ncf_common_updated|rudder_ncf_common_update_error|rudder_ncf_local_updated|rudder_ncf_local_update_error|config|no_update|rudder_ncf_hash_update_error|rudder_ncf_hash_update_repaired)::
      "any" usebundle => rudder_common_report("Common", "result_success", "&TRACKINGKEY&", "Update", "None", "Rudder policy, tools and ncf instance are already up to date. No action required.");

Actions #3

Updated by Nicolas CHARLES about 7 years ago

  • Subject changed from missing "update" reports on Relay to Random missing "update" reports on Relay

I tried to reproduce it, same system, same day, without any luck :(

Actions #4

Updated by Nicolas CHARLES about 7 years ago

issue is

    "rudder_ncf_hash_update_ok": true,
    "rudder_ncf_hash_update_repaired": true,

having both classes present kept status (depend on not rudder_ncf_hash_update_repaired), but it's still not repaired (as rudder_ncf_common_updated_ok and rudder_ncf_local_updated_ok are defined)
I don't know WHY this condition happens (repaired, but nothing to repair)

Actions #5

Updated by François ARMAND about 7 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility changed from Getting started - demo | first install | level 1 Techniques to Operational - other Techniques | Technique editor | Rudder settings

We are lowering the visibility to "operationnal" because relays are not a basic feature (not likelly in demo)

Actions #6

Updated by Benoît PECCATTE about 7 years ago

  • Priority set to 17
Actions #7

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #8

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #9

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.21 to 3.1.22
  • Priority changed from 17 to 16
Actions #10

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 16 to 31
Actions #11

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.22 to 3.1.23
  • Priority changed from 31 to 30
Actions #12

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #13

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
  • Priority changed from 30 to 29
Actions #14

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.25 to 387
Actions #15

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 387 to 4.1.10
  • Priority changed from 29 to 28
Actions #16

Updated by Nicolas CHARLES over 6 years ago

  • Related to Bug #12137: Missing "update" reports on node added
Actions #17

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
  • Priority changed from 28 to 27
Actions #18

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
Actions #19

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
Actions #20

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
Actions #21

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
Actions #22

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
Actions #23

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #24

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
  • Priority changed from 27 to 0
Actions #25

Updated by François ARMAND over 5 years ago

  • Translation missing: en.field_tag_list set to Sponsored
Actions #26

Updated by François ARMAND over 5 years ago

  • User visibility changed from Operational - other Techniques | Technique editor | Rudder settings to Operational - other Techniques | Rudder settings | Plugins
  • Priority changed from 0 to 54
Actions #27

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #28

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #29

Updated by François ARMAND about 5 years ago

  • Target version changed from 4.1.20 to 4.1.21
Actions #30

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.21 to 4.1.22
Actions #31

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.22 to 4.1.23
Actions #32

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.23 to 4.1.24
Actions #33

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.1.24 to 588
Actions #34

Updated by Félix DALLIDET almost 5 years ago

  • Target version changed from 588 to 5.0.13

Still there, quite easy to reproduce, just modify a GM with a relay and double run the agent with update on it.

Actions #35

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #36

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #37

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #38

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #39

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
  • Priority changed from 54 to 55
Actions #40

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
  • Priority changed from 55 to 56
Actions #41

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.19 to 5.0.20
  • Priority changed from 56 to 57
Actions #42

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
  • Priority changed from 57 to 58
Actions #43

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
  • Priority changed from 58 to 61
Actions #44

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #45

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
  • Priority changed from 61 to 62
Actions #46

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #47

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
  • Priority changed from 62 to 63
Actions #48

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
  • Priority changed from 63 to 64
Actions #49

Updated by Alexis Mousset over 2 years ago

  • Subject changed from Random missing "update" reports on Relay to Missing "update" reports on Relay in rare cases
Actions #50

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.19 to 6.1.20
  • Priority changed from 64 to 65
Actions #51

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.1.20 to 6.1.21
Actions #53

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.1.21 to old 6.1 issues to relocate
  • Priority changed from 65 to 32
Actions #54

Updated by Alexis Mousset over 1 year ago

  • Target version changed from old 6.1 issues to relocate to old 6.2 issues to relocate
  • Priority changed from 32 to 0
Actions #55

Updated by Alexis Mousset 10 months ago

  • Status changed from New to Rejected
  • Regression set to No

not seen for a long time

Actions

Also available in: Atom PDF