Project

General

Profile

Actions

Bug #10645

closed

Proxy error when accepting 500 inventories at the same time

Added by Nicolas CHARLES about 7 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Nodes & inventories
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Infrequent - complex configurations | third party integrations
Effort required:
Priority:
21
Name check:
Fix check:
Regression:

Description

When accepting 500 inventories at the same time, I get the following error:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request POST /rudder/secure/nodeManager/manageNewNode.

Reason: Error reading from remote server

Things are going well in backstages, but still, this is confusing


Related issues 2 (1 open1 closed)

Related to Rudder - Bug #10646: "SocketException(message='Socket closed'" error at the end of generation with 500 nodesReleasedNicolas CHARLESActions
Is duplicate of Rudder - Architecture #5367: Make node acceptance process asynchronousNewActions
Actions #1

Updated by Nicolas CHARLES about 7 years ago

actually, it may have broken things (it may be the cause of #10646)

Actions #2

Updated by Nicolas CHARLES about 7 years ago

  • Related to Bug #10646: "SocketException(message='Socket closed'" error at the end of generation with 500 nodes added
Actions #3

Updated by Jonathan CLARKE about 7 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • Priority changed from 0 to 6

Assuming this is working well in the backend as you suggest, this would be a Minor severity ticket. If this does break something, either merge it with #10646, or increase the severity.

Actions #4

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 4.1.2 to 4.1.3
Actions #5

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 4.1.3 to 4.1.4
Actions #6

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.1.4 to 4.1.5
Actions #7

Updated by Alexis Mousset almost 7 years ago

  • Target version changed from 4.1.5 to 4.1.6
Actions #8

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 6 to 21
Actions #9

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.1.6 to 4.1.7
Actions #10

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.1.7 to 4.1.8
Actions #11

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.8 to 4.1.9
  • Priority changed from 21 to 20
Actions #12

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.9 to 4.1.10
  • Priority changed from 20 to 19
Actions #13

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
Actions #14

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
  • Priority changed from 19 to 18
Actions #15

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
Actions #16

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
Actions #17

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
Actions #18

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
Actions #19

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #20

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
Actions #21

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #22

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #23

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.1.20 to 4.1.21
Actions #24

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.21 to 4.1.22
Actions #25

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.22 to 4.1.23
Actions #26

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.23 to 4.1.24
Actions #27

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.1.24 to 588
Actions #28

Updated by Benoît PECCATTE almost 5 years ago

  • Target version changed from 588 to 5.0.13
Actions #29

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #30

Updated by Nicolas CHARLES almost 5 years ago

This still happens. I think it's because the process to accept 500 nodes is too slow, and the action is not async - so it fails

Actions #31

Updated by Nicolas CHARLES almost 5 years ago

plus generation kicks in while the process goes on

Actions #32

Updated by Nicolas CHARLES almost 5 years ago

i got one error
75d7-4df6-941e-c0ae3115e7e0.xml'. You can safely ignore that warning if the
file was already existing in Git and was not modified by that archive.
[2019-09-02 20:08:32] ERROR nodes.pending - Error when trying to accept node f886ece3-165c-42f3-ba55-d840a86b3499. Rollbacking. <
The connection is not established.
[2019-09-02 20:08:32] ERROR nodes.pending - Unit acceptor error for node NodeId(f886ece3-165c-42f3-ba55-d840a86b3499) <- Error when trying to accept node f886ece3-165c-42f3-ba55-d840a86b3499 <- The connection is not established.

Actions #33

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #34

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #35

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #36

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #37

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
  • Priority changed from 18 to 19
Actions #38

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #39

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #40

Updated by Nicolas CHARLES over 3 years ago

  • Priority changed from 19 to 20

i reproduced it on a very memory coonstraint system.
could be a memory issue

Actions #41

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #42

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #43

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #44

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
  • Priority changed from 20 to 21
Actions #45

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #46

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #47

Updated by François ARMAND over 2 years ago

Actions #48

Updated by François ARMAND over 2 years ago

  • Status changed from New to Rejected

I'm closing that issue as a duplicate of #5367

Actions

Also available in: Atom PDF