Project

General

Profile

Actions

Bug #11251

closed

Setting MULTIINSTANCE to false in metadata.xml breaks multivalued section.

Added by Dmitry Svyatogorov almost 7 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Techniques
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Very Small
Priority:
0
Name check:
Fix check:
Regression:

Description

In "metadata.xml":
  1. Set <MULTIINSTANCE>false</MULTIINSTANCE>
  2. Make <SECTION name="Test" multivalued="true" etc...
  3. Only the first section is processed while generating promises from such directive
    Expect to process all sections of selected single directive based on such technique.
Actions #1

Updated by Benoît PECCATTE almost 7 years ago

  • Target version changed from 4.1.7 to 3.1.23
  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority changed from 0 to 52
Actions #2

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #3

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.24 to 3.1.25
  • Priority changed from 52 to 50
Actions #4

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.25 to 387
  • Priority changed from 50 to 49
Actions #5

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 387 to 4.1.10
Actions #6

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
  • Priority changed from 49 to 47
Actions #7

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
  • Priority changed from 47 to 46
Actions #8

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
  • Priority changed from 46 to 45
Actions #9

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 4.1.13 to 411
Actions #10

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 411 to 4.1.13
Actions #11

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
  • Priority changed from 45 to 44
Actions #12

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
  • Priority changed from 44 to 43
Actions #13

Updated by Nicolas CHARLES almost 6 years ago

  • Effort required set to Very Small
  • Priority changed from 43 to 67

setting to very small for reproducing. we had some issues at some point due to duplicate variables name - could be related

Actions #14

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.15 to 4.1.16
Actions #15

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #16

Updated by Nicolas CHARLES over 5 years ago

  • Status changed from New to Rejected
  • Priority changed from 67 to 0

Hi Dmitry,

I cannot reproduce the issue. Here is my tests files:

metadata.xml

<TECHNIQUE name="Multiple sections">
  <DESCRIPTION>This technique to multiple section
  </DESCRIPTION>

  <BUNDLES>
    <NAME>multisection</NAME>
  </BUNDLES>
  <MULTIINSTANCE>false</MULTIINSTANCE>
  <TMLS>
    <TML name="main"/>
  </TMLS>

  <TRACKINGVARIABLE>
    <SAMESIZEAS>MULTIVALUES</SAMESIZEAS>
  </TRACKINGVARIABLE>

  <SECTIONS>
    <SECTION name="Test" multivalued="true">
      <INPUT>
        <NAME>MULTIVALUES</NAME>
        <DESCRIPTION>multi valued</DESCRIPTION>
      </INPUT>
    </SECTION>
  </SECTIONS>

</TECHNIQUE>

main.st file

bundle agent multisection
{
  vars:

    &MULTIVALUES:{path |"file[&i&][path]" string => "&path&";
    }&

    &TRACKINGKEY:{directiveId |"file[&i&][uuid]" string => "&directiveId&";
    }&
}

Resulting file, with the values one for Test #1, two for Test #2 and three for Test #3 is

bundle agent multisection
{
  vars:

    "file[1][path]" string => "one";
        "file[2][path]" string => "two";
        "file[3][path]" string => "three";

    "file[1][uuid]" string => "32377fd7-02fd-43d0-aab7-28460a91347b@@aec180c5-c831-4f56-8d5c-abd61b75991d@@0";

}

I'm rejecting this issue, but feel free to reopen it with a test case that exhibit the issue, so that we can either fix the code, or the documentation

Thank you !

Actions

Also available in: Atom PDF