Project

General

Profile

Actions

Bug #11348

closed

Impossible to save a new technique when last char in a parameter is a backslash

Added by Alexis Mousset almost 7 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
N/A
Category:
Web - Technique editor
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

I get a generic error message in the interface, which is not helpful, and in the logs:

[Tue Sep 12 10:25:25.930461 2017] [wsgi:error] [pid 19007:tid 139863704770304] ERROR: Could not write technique 'toto' from path /var/rudder/configuration-repository/ncf, cause is: Error while running post-hook command /var/rudder/configuration-repository/ncf/ncf-hooks.d/post.write_technique.50_rudderify.sh /var/rudder/configuration-repository/ncf toto
[Tue Sep 12 10:25:25.930807 2017] [wsgi:error] [pid 19007:tid 139863704770304] INFO: Alternative source path added: /var/rudder/configuration-repository/ncf
[Tue Sep 12 10:25:25.930840 2017] [wsgi:error] [pid 19007:tid 139863704770304] ERROR: Could not parse Technique 'toto'
[Tue Sep 12 10:25:25.930844 2017] [wsgi:error] [pid 19007:tid 139863704770304]  caused by : Error while running post-hook command cf-promises -pjson -f /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf
[Tue Sep 12 10:25:25.930848 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:9:92: error: syntax error
[Tue Sep 12 10:25:25.930865 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.930868 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                            ^
[Tue Sep 12 10:25:25.930896 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:9:92: error: Expected ',', wrong input 'any'
[Tue Sep 12 10:25:25.930901 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.930905 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                            ^
[Tue Sep 12 10:25:25.930920 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:10:101: error: Invalid function argument, wrong input '");
[Tue Sep 12 10:25:25.930931 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "'
[Tue Sep 12 10:25:25.930936 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.930939 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                     ^
[Tue Sep 12 10:25:25.930942 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:10:112: error: Expected ',', wrong input 'method_call'
[Tue Sep 12 10:25:25.931016 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931028 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                ^
[Tue Sep 12 10:25:25.931036 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:10:145: error: Invalid function argument, wrong input '" usebundle => directory_absent("'
[Tue Sep 12 10:25:25.931055 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931062 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                                                 ^
[Tue Sep 12 10:25:25.931066 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:10:147: error: Expected ',', wrong input 'C:'
[Tue Sep 12 10:25:25.931072 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931083 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                                                   ^
[Tue Sep 12 10:25:25.931090 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:10:148: error: Invalid function argument, wrong input '\\'
[Tue Sep 12 10:25:25.931094 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931098 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                                                    ^
[Tue Sep 12 10:25:25.931103 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:10:152: error: Expected ',', wrong input 'toto'
[Tue Sep 12 10:25:25.931106 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931110 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                                                        ^
[Tue Sep 12 10:25:25.931114 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:10:156: error: Invalid function argument, wrong input '", "'
[Tue Sep 12 10:25:25.931117 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931121 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                                                            ^
[Tue Sep 12 10:25:25.931128 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:11:188: error: Expected ',', wrong input '"),
[Tue Sep 12 10:25:25.931140 2017] [wsgi:error] [pid 19007:tid 139863704770304]       ifvarclass => concat("'
[Tue Sep 12 10:25:25.931150 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931205 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                                                                                            ^
[Tue Sep 12 10:25:25.931228 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:11:191: error: Invalid function argument, wrong input 'any'
[Tue Sep 12 10:25:25.931254 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931269 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                                                                                               ^
[Tue Sep 12 10:25:25.931283 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:12:200: error: Expected ',', wrong input '");
[Tue Sep 12 10:25:25.931289 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "'
[Tue Sep 12 10:25:25.931293 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931304 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                                                                                                        ^
[Tue Sep 12 10:25:25.931319 2017] [wsgi:error] [pid 19007:tid 139863704770304] /var/rudder/configuration-repository/ncf/50_techniques/toto/toto.cf:12:211: error: Invalid function argument, wrong input 'method_call'
[Tue Sep 12 10:25:25.931322 2017] [wsgi:error] [pid 19007:tid 139863704770304]     "method_call" usebundle => command_execution("dir C:\\"),
[Tue Sep 12 10:25:25.931326 2017] [wsgi:error] [pid 19007:tid 139863704770304]                                                                                                                                                                                                                   ^
[Tue Sep 12 10:25:25.931330 2017] [wsgi:error] [pid 19007:tid 139863704770304] Too many errors
[Tue Sep 12 10:25:25.931335 2017] [wsgi:error] [pid 19007:tid 139863704770304] 
[Tue Sep 12 10:25:25.931337 2017] [wsgi:error] [pid 19007:tid 139863704770304] Error: Unable to create Rudder Technique files related to ncf Technique toto, cannot find ncf Technique toto
[Tue Sep 12 10:25:25.931338 2017] [wsgi:error] [pid 19007:tid 139863704770304] None
[Tue Sep 12 10:25:25.931340 2017] [wsgi:error] [pid 19007:tid 139863704770304] 


Related issues 2 (0 open2 closed)

Related to Rudder - Bug #13890: Constant error message in Technique Editor when an invalid technique as been createdResolvedVincent MEMBRÉActions
Is duplicate of Rudder - Bug #7745: \ are not escaped in technique editorResolvedActions
Actions #1

Updated by Alexis Mousset almost 7 years ago

Works when changing dir C:\ to dir C:\\.

Actions #2

Updated by François ARMAND over 6 years ago

Is this still the case?

Actions #3

Updated by Alexis Mousset over 6 years ago

  • Subject changed from Impossible to save a new technique to Impossible to save a new technique when last char in a parameter is a backslash

Yes, it happens when a parameters ends by a backslash.

Actions #4

Updated by Benoît PECCATTE over 6 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority changed from 0 to 51
Actions #5

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from master to 4.2.2
Actions #6

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.2.2 to 4.2.3
Actions #7

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.2.3 to 4.2.4
  • Priority changed from 51 to 50
Actions #8

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.2.4 to 4.2.5
  • Priority changed from 50 to 48
Actions #9

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.2.5 to 4.2.6
  • Priority changed from 48 to 47
Actions #10

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.2.6 to 4.2.7
  • Priority changed from 47 to 46
Actions #11

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.2.7 to 414
  • Priority changed from 46 to 45
Actions #12

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 414 to 4.3.4
  • Priority changed from 45 to 44
Actions #13

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.3.4 to 4.3.5
Actions #14

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.5 to 4.3.6
  • Priority changed from 44 to 43
Actions #15

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.6 to 4.3.7
Actions #16

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.7 to 4.3.8
  • Priority changed from 43 to 0
Actions #17

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.8 to 4.3.9
Actions #18

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.3.9 to 4.3.10
Actions #19

Updated by Alexis Mousset over 5 years ago

  • Related to Bug #13890: Constant error message in Technique Editor when an invalid technique as been created added
Actions #20

Updated by Alexis Mousset over 5 years ago

NOTE: It seems to break when starting a line with two slashes.

Actions #21

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.3.10 to 4.3.11
Actions #22

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.11 to 4.3.12
Actions #23

Updated by Benoît PECCATTE about 5 years ago

  • Target version changed from 4.3.12 to 5.0.10
Actions #24

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.10 to 5.0.11
Actions #25

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.11 to 5.0.12
Actions #26

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.12 to 5.0.13
Actions #27

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #28

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #29

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #30

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #31

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #32

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #33

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #34

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #35

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #36

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #37

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #38

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #39

Updated by Benoît PECCATTE over 2 years ago

  • Project changed from 41 to Rudder
  • Category changed from Technique editor - API to Web - Technique editor
Actions #40

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #41

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #42

Updated by François ARMAND over 2 years ago

  • Is duplicate of Bug #7745: \ are not escaped in technique editor added
Actions #43

Updated by François ARMAND over 2 years ago

  • Status changed from New to Resolved

It's corrected in 7.0.

Actions

Also available in: Atom PDF