Project

General

Profile

Actions

Bug #13890

closed

Constant error message in Technique Editor when an invalid technique as been created

Added by Nicolas CHARLES over 5 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
N/A
Category:
Web - Technique editor
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Getting started - demo | first install | Technique editor and level 1 Techniques
Effort required:
Very Small
Priority:
84
Name check:
Fix check:
Regression:

Description

If we create a technique, with a parameter finishing with \ , we get an error message at save
But the file is still saved, and when we go back to tehcnique editor we have again a message

An Error occured! Could not parse Technique 'invalid_technique'
Details:

 caused by : Error while running post-hook command cf-promises -pjson -f /var/rudder/configuration-repository/ncf/50_techniques/invalid_technique/invalid_technique.cf
/var/rudder/configuration-repository/ncf/50_techniques/invalid_technique/invalid_technique.cf:9:126: error: syntax error
    "method_call_context_0" usebundle => _method_reporting_context("File absent", "/tmp/some_broken_file\");
                                                                                                                             ^
/var/rudder/configuration-repository/ncf/50_techniques/invalid_technique/invalid_technique.cf:9:126: error: Invalid function argument, wrong input 'method_call'
    "method_call_context_0" usebundle => _method_reporting_context("File absent", "/tmp/some_broken_file\");
                                                                                                                             ^
/var/rudder/configuration-repository/ncf/50_techniques/invalid_technique/invalid_technique.cf:9:154: error: Expected ',', wrong input '" usebundle => file_absent("'
    "method_call_context_0" usebundle => _method_reporting_context("File absent", "/tmp/some_broken_file\");
                                                                                                                                                         ^
/var/rudder/configuration-repository/ncf/50_techniques/invalid_technique/invalid_technique.cf:9:155: error: Invalid function argument, wrong input '/'
    "method_call_context_0" usebundle => _method_reporting_context("File absent", "/tmp/some_broken_file\");
                                                                                                                                                          ^
/var/rudder/configuration-repository/ncf/50_techniques/invalid_technique/invalid_technique.cf:9:158: error: Expected ',', wrong input 'tmp'
    "method_call_context_0" usebundle => _method_reporting_context("File absent", "/tmp/some_broken_file\");

The only way to get out of that is to modify the .cf file

We should be able to check the file before saving, or if it's not possible, save it somewhere safe first, validate, and move it to final position

Targeting to 4.3, but the full lfix may be too hard to get there


Related issues 3 (0 open3 closed)

Related to Rudder - Bug #10723: Escaping backslash+double quote in NCF method file_ensure_lines_presentResolvedActions
Related to Rudder - Bug #7745: \ are not escaped in technique editorResolvedActions
Related to Rudder - Bug #11348: Impossible to save a new technique when last char in a parameter is a backslashResolvedVincent MEMBRÉActions
Actions #1

Updated by Nicolas CHARLES over 5 years ago

a first workaround could be to escape last \

Actions #2

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.7 to 4.3.8
Actions #3

Updated by Nicolas CHARLES over 5 years ago

  • Related to Bug #10723: Escaping backslash+double quote in NCF method file_ensure_lines_present added
Actions #4

Updated by Nicolas CHARLES over 5 years ago

  • Related to Bug #7745: \ are not escaped in technique editor added
Actions #6

Updated by François ARMAND over 5 years ago

  • Assignee set to Vincent MEMBRÉ

We need to still display the broken technique with at least the "delete" button + the error message in the technique details + not the error message in notification.

Actions #7

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.3.8 to 4.3.9
  • Priority changed from 70 to 69
Actions #8

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.3.9 to 4.3.10
  • Priority changed from 69 to 68
Actions #9

Updated by Alexis Mousset over 5 years ago

  • Related to Bug #11348: Impossible to save a new technique when last char in a parameter is a backslash added
Actions #10

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.3.10 to 4.3.11
  • Priority changed from 68 to 67
Actions #11

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.11 to 4.3.12
  • Priority changed from 67 to 66
Actions #12

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.12 to 4.3.13
  • Priority changed from 66 to 65
Actions #13

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.3.13 to 4.3.14
  • Priority changed from 65 to 64
Actions #14

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.3.14 to 587
  • Priority changed from 64 to 63
Actions #15

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 587 to 4.3.14
Actions #16

Updated by Alexis Mousset almost 5 years ago

  • Target version changed from 4.3.14 to 5.0.13

very likely not fixed.

Actions #17

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
  • Priority changed from 63 to 61
Actions #18

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
  • Priority changed from 61 to 60
Actions #19

Updated by François ARMAND over 4 years ago

  • Priority changed from 60 to 58

It should be "just" an try/catch away: try { parse } catch (error) { default stub "error technique" which is handle specificly in editor }

Actions #20

Updated by François ARMAND over 4 years ago

  • Effort required set to Very Small
  • Priority changed from 58 to 82

budget: very small to at least check if problem still here (and perhaps correction is short)

Actions #21

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #22

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #23

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #24

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #25

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #26

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #27

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #28

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #29

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #30

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #31

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #32

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
  • Priority changed from 82 to 83
Actions #33

Updated by François ARMAND over 2 years ago

  • Status changed from New to Resolved
  • Priority changed from 83 to 84

Technique editor technique generation changed massively since then. That case was not reproduced, and other similar problem were corrected. I'm closing it, and we will open new tickets if needed.

Actions

Also available in: Atom PDF