Project

General

Profile

Bug #11996

Broken reporting on Rudder 4.3

Added by Nicolas CHARLES almost 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
N/A
Category:
System techniques
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Priority:
68

Description

E| error         ${t_name}                 ${c_name}                 ${c_key}           Presence of package curl in any version could not be repaired
E| error         Inventory                 inventory                                    Installing 'curl' failed. Inventory registration will fail if curl is unavailable
E| compliant     Inventory                 inventory                                    Next inventory scheduled between 00:00 and 06:00
E| compliant     server-roles              Check logrotate configur|                    The logrotate configuration is correct
E| compliant     server-roles              Check LDAP in rudder-web|                    Web interface configuration files are correct (checked LDAP password)
E| compliant     server-roles              Check LDAP credentials                       OpenLDAP configuration file is correct (checked rootdn password)
E| compliant     server-roles              Check rudder-passwords.c|                    Rudder passwords file is present and secure
E| compliant     server-roles              Check SQL in rudder-weba|                    Web interface configuration files are OK (checked SQL password)
E| compliant     server-roles              Check SQL credentials                        PostgreSQL user account's password is correct and works
E| compliant     server-roles              Check allowed networks c|                    Allowed networks configuration is correct
E| compliant     server-roles              Check WebDAV credentials                     Apache WebDAV user and password are OK
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Check if the service apache2 is started using ps was correct
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Ensure that service apache2 is running was correct
E| compliant     server-roles              Check apache process                         Check apache process running was correct
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Check if service apache2 is started at boot was correct
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Ensure service apache2 is started at boot was correct
E| compliant     server-roles              Check apache boot script                     Check apache boot starting parameters was correct
E| error         ${t_name}                 ${c_name}                 ${c_key}           Check if the service .*java.*/opt/rudder/jetty7/start.jar is started using ps could not be repaired
E| repaired      ${t_name}                 ${c_name}                 ${c_key}           Run action start on service rudder-jetty was repaired
E| repaired      ${t_name}                 ${c_name}                 ${c_key}           Start service rudder-jetty was repaired
E| repaired      ${t_name}                 ${c_name}                 ${c_key}           Ensure that service rudder-jetty is running was repaired
E| repaired      server-roles              Check jetty process                          Check jetty process running was repaired
E| compliant     server-roles              Check configuration-repo|                    The /var/rudder/configuration-repository directory is present
E| compliant     server-roles              Check configuration-repo|                    The /var/rudder/configuration-repository git lock file is not present or not older than 5 minutes
E| compliant     server-roles              Check rudder status                          The http://localhost:8080/rudder/api/status web interface is running
E| compliant     server-roles              Check endpoint status                        The http://localhost:8080/endpoint/api/status web interface is running
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Check if the service /opt/rudder/libexec/slapd is started using ps was correct
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Ensure that service rudder-slapd is running was correct
E| compliant     server-roles              Check slapd process                          Check slapd process running was correct
E| compliant     server-roles              Check PostgreSQL configu|                    There is no need of specific PostgreSQL configuration on this system
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Check if the service postgres:.* writer process is started using ps was correct
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Ensure that service postgresql is running was correct
E| compliant     server-roles              Check postgresql process                     Check postgresql process running was correct
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Check if service postgresql is started at boot was correct
E| compliant     ${t_name}                 ${c_name}                 ${c_key}           Ensure service postgresql is started at boot was correct

Related issues

Related to ncf - Bug #12252: disable_reporting is cleared in some generic methodRejectedActions
Is duplicate of ncf - Architecture #12172: Prevent reporting of inner methods in Rudder ReleasedActions

History

#1

Updated by Nicolas CHARLES almost 2 years ago

intersetingly, at the end, we have

E| repaired      test technique            command_name              /bin/true          Execute the command /bin/true was repaired
E| compliant     test technique            command_name              /bin/true          Check if the service rsyslog is started was correct
E| compliant     test technique            command_name              /bin/true          Ensure that service rsyslog is running was correct


we have leaking data from techniques to system technique

#2

Updated by Benoît PECCATTE over 1 year ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Getting started - demo | first install | level 1 Techniques
  • Priority changed from 0 to 70
#3

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 4.3.0~beta1 to 4.3.0~rc1
#4

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 4.3.0~rc1 to 4.3.0~rc2
  • Priority changed from 70 to 69
#5

Updated by François ARMAND over 1 year ago

  • Tags set to Blocking 4.3
#6

Updated by Nicolas CHARLES over 1 year ago

  • Tags deleted (Blocking 4.3)

This is not fixed, I have duplicate reports for service httpd:

E| compliant     server-roles              Check apache process                         Ensure that service httpd is running was correct
E| compliant     server-roles              Check apache process                         Check apache process running was correct
E| compliant     server-roles              Check apache boot script                     Ensure service httpd is started at boot was correct
E| compliant     server-roles              Check apache boot script                     Check apache boot starting parameters was correct

finally, I have this end report unexpected
E| compliant     Common                    Make sure syslog service|                    Ensure that service rsyslog is running was correct

#7

Updated by Nicolas CHARLES over 1 year ago

  • Related to Bug #12252: disable_reporting is cleared in some generic method added
#8

Updated by Nicolas CHARLES over 1 year ago

  • Assignee set to Nicolas CHARLES
  • Priority changed from 69 to 68

server-roles broken reports need to be handled in #12252

#9

Updated by Nicolas CHARLES over 1 year ago

  • Status changed from New to In progress
#10

Updated by Nicolas CHARLES over 1 year ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Nicolas CHARLES to Alexis MOUSSET
  • Pull Request set to https://github.com/Normation/rudder-techniques/pull/1267
#11

Updated by Nicolas CHARLES over 1 year ago

#12

Updated by Nicolas CHARLES over 1 year ago

  • Status changed from Pending technical review to Rejected

Fixed in #12172

Also available in: Atom PDF