Project

General

Profile

Bug #12678

Error with first inventory on debian 9.0

Added by Vincent DAVY almost 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Pull Request:
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Infrequent - complex configurations | third party integrations
Effort required:
Priority:
41

Description

I installed Rudder agent on a debian 9.0 VM and the inventory is never sent.
I went to the Rudder IRC and the support asked me to run the following command and post the output here:
bash -x /opt/rudder/bin/run-inventory -debug --local=/tmp/test.ocs

+ . /etc/profile
+++ id -u
++ '[' 0 -eq 0 ']'
++ PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
++ export PATH
++ '[' '' ']'
++ '[' -d /etc/profile.d ']'
++ for i in /etc/profile.d/*.sh
++ '[' -r /etc/profile.d/bash_completion.sh ']'
++ . /etc/profile.d/bash_completion.sh
+++ '[' -n '4.4.12(1)-release' -a -n '' -a -z '' ']'
++ for i in /etc/profile.d/*.sh
++ '[' -r /etc/profile.d/rudder-agent.sh ']'
++ . /etc/profile.d/rudder-agent.sh
+++ PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/var/rudder/cfengine-community/bin
+++ export PATH
+++ type manpath
++++ manpath
+++ MANPATH=/usr/local/man:/usr/local/share/man:/usr/share/man:/opt/rudder/share/man
+++ export MANPATH
++ unset i
+ OLDEST_SUPPORTED_FUSINV_VERSION=2.2
++ echo 2.2
++ sed 's%\.%%g'
+ OLDEST_SUPPORTED_FUSINV_VERSION_UNDOTTED=22
+ '[' -x /opt/rudder/bin/perl ']'
+ '[' -x /opt/rudder/bin/fusioninventory-agent ']'
+ command -v perl
+ echo '[info] FusionInventory instance: builtin - Perl instance: system'
[info] FusionInventory instance: builtin - Perl instance: system
+ perl -I /opt/rudder/lib/perl5 /opt/rudder/bin/fusioninventory-agent --config=none --no-task=Deploy -debug --local=/tmp/test.ocs
perl: symbol lookup error: /opt/rudder/lib/perl5/x86_64-linux-gnu-thread-multi/auto/List/Util/Util.so: undefined symbol: Perl_xs_handshake

perl version on my debian 9.0 is v5.20.2

#1

Updated by Nicolas CHARLES almost 3 years ago

Thank you for this detailed ticket.
Could you check the output of the command

perl -I /opt/rudder/lib/perl5 --version

as well as
perl --version

It seems that the version of perl used within Rudder is newer than the one on your system, hence the missing Perl_xs_handshake

#2

Updated by François ARMAND almost 3 years ago

Could it be https://www.rudder-project.org/redmine/issues/12599 ?

Would you mind trying to install libxml-treepp-perl?

#3

Updated by François ARMAND almost 3 years ago

  • Category set to Packaging
  • Target version set to 410
#4

Updated by Vincent DAVY almost 3 years ago

Tryed installing libxml-treepp-perl but I get the same error

#5

Updated by François ARMAND almost 3 years ago

Thanks for the information, we are going to look more carefuly to it. Thanks for the test, it helps a lot.

#6

Updated by Benoît PECCATTE almost 3 years ago

tried on a vanilla debian 9 and a rudder 4.3.1 and i cannot reproduce, which version of rudder are you using ?

#7

Updated by Vincent DAVY almost 3 years ago

Latest Rudder version
It was on debian 9.0 and not 9.4

#8

Updated by Benoît PECCATTE almost 3 years ago

OK, tried with this debian 9.0 https://app.vagrantup.com/bento/boxes/debian-9.0 and i cannot reproduce either

can you give us the result of ldd /opt/rudder/lib/perl5/x86_64-linux-gnu-thread-multi/auto/List/Util/Util.so ?

#9

Updated by Vincent DAVY almost 3 years ago

Here is the command outpute :

$ ldd /opt/rudder/lib/perl5/x86_64-linux-gnu-thread-multi/auto/List/Util/Util.so
    linux-vdso.so.1 (0x00007fff249b1000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ff2506ba000)
    /lib64/ld-linux-x86-64.so.2 (0x000055d11dfa9000)

#10

Updated by Benoît PECCATTE almost 3 years ago

What is the output of "dpkg -l | grep perl" ?

#11

Updated by Benoît PECCATTE almost 3 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Infrequent - complex configurations | third party integrations
  • Priority changed from 0 to 41
#12

Updated by Vincent DAVY almost 3 years ago

Here is the requested output :

$ dpkg -l | grep perl
ii  libalgorithm-c3-perl            0.10-1                         all          Perl module for merging hierarchies using the C3 algorithm
ii  libalgorithm-diff-perl          1.19.03-1                      all          module to find differences between files
ii  libalgorithm-diff-xs-perl       0.04-3+b1                      amd64        module to find differences between files (XS accelerated)
ii  libalgorithm-merge-perl         0.08-3                         all          Perl module for three-way merge of textual data
ii  libarchive-extract-perl         0.80-1                         all          generic archive extracting module
ii  libauthen-sasl-perl             2.1600-1                       all          Authen::SASL - SASL Authentication framework
ii  libcgi-fast-perl                1:2.12-1                       all          CGI subclass for work with FCGI
ii  libcgi-pm-perl                  4.35-1                         all          module for Common Gateway Interface applications
ii  libclass-accessor-perl          0.34-1                         all          Perl module that automatically generates accessors
ii  libclass-c3-perl                0.32-1                         all          pragma for using the C3 method resolution order
ii  libclass-c3-xs-perl             0.13-2+b1                      amd64        Perl module to accelerate Class::C3
ii  libclass-isa-perl               0.36-5                         all          report the search path for a class's ISA tree
ii  libcpan-meta-perl               2.142690-1                     all          Perl module to access CPAN distributions metadata
ii  libdata-optlist-perl            0.110-1                        all          module to parse and validate simple name/value option pairs
ii  libdata-section-perl            0.200006-1                     all          module to read chunks of data from a module's DATA section
ii  libdpkg-perl                    1.18.24                        all          Dpkg perl modules
ii  libencode-locale-perl           1.05-1                         all          utility to determine the locale encoding
ii  liberror-perl                   0.17024-1                      all          Perl module for error/exception handling in an OO-ish way
ii  libfcgi-perl                    0.77-1+deb8u1                  amd64        helper module for FastCGI
ii  libfile-fcntllock-perl          0.22-1+b1                      amd64        Perl module for file locking with fcntl(2)
ii  libfile-listing-perl            6.04-1                         all          module to parse directory listings
ii  libfont-afm-perl                1.20-2                         all          Font::AFM - Interface to Adobe Font Metrics files
ii  libhtml-form-perl               6.03-1                         all          module that represents an HTML form element
ii  libhtml-format-perl             2.12-1                         all          module for transforming HTML into various formats
ii  libhtml-parser-perl             3.71-1+b3                      amd64        collection of modules that parse HTML text documents
ii  libhtml-tagset-perl             3.20-3                         all          Data tables pertaining to HTML
ii  libhtml-tree-perl               5.03-2                         all          Perl module to represent and create HTML syntax trees
ii  libhttp-cookies-perl            6.01-1                         all          HTTP cookie jars
ii  libhttp-daemon-perl             6.01-1                         all          simple http server class
ii  libhttp-date-perl               6.02-1                         all          module of date conversion routines
ii  libhttp-message-perl            6.11-1                         all          perl interface to HTTP style messages
ii  libhttp-negotiate-perl          6.00-2                         all          implementation of content negotiation
ii  libintl-perl                    1.23-1+deb8u1                  all          Uniforum message translations system compatible i18n library
ii  libio-html-perl                 1.001-1                        all          open an HTML file with automatic charset detection
ii  libio-socket-ip-perl            0.38-1                         all          module for using IPv4 and IPv6 sockets in a protocol-independent way
ii  libio-socket-ssl-perl           2.044-1                        all          Perl module implementing object oriented interface to SSL sockets
ii  libio-string-perl               1.08-3                         all          Emulate IO::File interface for in-core strings
ii  liblocale-gettext-perl          1.05-8+b1                      amd64        module using libc functions for internationalization in Perl
ii  liblog-message-perl             0.8-1                          all          powerful and flexible message logging mechanism
ii  liblog-message-simple-perl      0.10-2                         all          simplified interface to Log::Message
ii  liblwp-mediatypes-perl          6.02-1                         all          module to guess media type for a file or a URL
ii  liblwp-protocol-https-perl      6.06-2                         all          HTTPS driver for LWP::UserAgent
ii  libmailtools-perl               2.18-1                         all          Manipulate email in perl programs
ii  libmodule-build-perl            0.422000-1                     all          framework for building and installing Perl modules
ii  libmodule-load-conditional-perl 0.68-1                         all          module for looking up information about modules
ii  libmodule-pluggable-perl        5.1-1                          all          module for giving  modules the ability to have plugins
ii  libmodule-signature-perl        0.81-1                         all          module to manipulate CPAN SIGNATURE files
ii  libmro-compat-perl              0.12-1                         all          mro::* interface compatibility for Perls < 5.9.5
ii  libnet-http-perl                6.12-1                         all          module providing low-level HTTP connection client
ii  libnet-smtp-ssl-perl            1.04-1                         all          Perl module providing SSL support to Net::SMTP
ii  libnet-ssleay-perl              1.65-1+deb8u1                  amd64        Perl module for Secure Sockets Layer (SSL)
ii  libpackage-constants-perl       0.06-1                         all          module to list constants defined in a package
ii  libparams-util-perl             1.07-2+b1                      amd64        Perl extension for simple stand-alone param checking functions
ii  libparse-debianchangelog-perl   1.2.0-12                       all          parse Debian changelogs and output them in other formats
ii  libpod-latex-perl               0.61-2                         all          module to convert Pod data to formatted LaTeX
ii  libpod-readme-perl              0.11-1                         all          Perl module to convert POD to README file
ii  libregexp-common-perl           2016060801-1                   all          module with common regular expressions
ii  libsoftware-license-perl        0.103012-1                     all          module providing templated software licenses
ii  libsub-exporter-perl            0.986-1                        all          sophisticated exporter for custom-built routines
ii  libsub-install-perl             0.928-1                        all          module for installing subroutines into packages easily
ii  libsub-name-perl                0.12-1                         amd64        module for assigning a new name to referenced sub
ii  libswitch-perl                  2.17-2                         all          switch statement for Perl
ii  libterm-ui-perl                 0.46-1                         all          Term::ReadLine UI made easy
ii  libtext-charwidth-perl          0.04-7+b3                      amd64        get display widths of characters on the terminal
ii  libtext-iconv-perl              1.7-5+b2                       amd64        converts between character sets in Perl
ii  libtext-soundex-perl            3.4-1+b2                       amd64        implementation of the soundex algorithm
ii  libtext-template-perl           1.46-1                         all          perl module to process text templates
ii  libtext-unidecode-perl          1.30-1                         all          US-ASCII transliterations of Unicode text
ii  libtext-wrapi18n-perl           0.06-7.1                       all          internationalized substitute of Text::Wrap
ii  libtimedate-perl                2.3000-2                       all          collection of modules to manipulate date/time information
ii  liburi-perl                     1.71-1                         all          module to manipulate and access URI strings
ii  libwww-perl                     6.15-1                         all          simple and consistent interface to the world-wide web
ii  libwww-robotrules-perl          6.01-1                         all          database of robots.txt-derived permissions
ii  libxml-libxml-perl              2.0116+dfsg-1+deb8u2           amd64        Perl interface to the libxml2 library
ii  libxml-namespacesupport-perl    1.11-1                         all          Perl module for supporting simple generic namespaces
ii  libxml-parser-perl              2.41-3                         amd64        Perl module for parsing XML files
ii  libxml-sax-base-perl            1.07-1                         all          base class for SAX drivers and filters
ii  libxml-sax-expat-perl           0.40-2                         all          Perl module for a SAX2 driver for Expat (XML::Parser)
ii  libxml-sax-perl                 0.99+dfsg-2                    all          Perl module for using and building Perl SAX2 XML processors
ii  perl                            5.20.2-3+deb8u10               amd64        Larry Wall's Practical Extraction and Report Language
ii  perl-base                       5.20.2-3+deb8u10               amd64        minimal Perl system
ii  perl-modules                    5.20.2-3+deb8u10               all          Core Perl modules
#13

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 410 to 4.3.2
#14

Updated by Benoît PECCATTE almost 3 years ago

I find more than one thing suspicious here :
- you don't have a libperl package
- you have perl 5.20 whereas debian 9 provides perl 5.24
- some of your packages have a deb8u1 version which means they come from debian 8

This makes me wonder if your upgrade from debian 8 to debian 9 has properly terminated.

#15

Updated by Vincent DAVY almost 3 years ago

You are right.

After talking with the team who installed the VM, they said to me the upgrade from debian 8 to 9 was not very successfull.
So I am pretty sure it is not working properly due to this bad upgrade.

Thansk for your help

#16

Updated by Benoît PECCATTE almost 3 years ago

  • Status changed from New to Rejected

Reject as it doesn't seem to be a real bug.

Also available in: Atom PDF