Project

General

Profile

Actions

Bug #12883

closed

policy generation error "Conflicting arity in calling bundle log_rudder"

Added by Tobias Ell almost 6 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
50
Name check:
Fix check:
Regression:

Description

Environment:
centOS 7.5
rudder server 4.3.2

Because of problems with reporting I upgraded from 4.1.12 to 4.3.2
I followed the upgrade instructions but now I get error:

Policy update error for process '3140' at 2018-07-04 12:16:50
⇨ Cannot write configuration node
⇨ Exit code=1 for hook: '/opt/rudder/etc/hooks.d/policy-generation-node-ready/10-cf-promise-check'. stdout: stderr: '/var/rudder/share/681525d5-2318-4e3f-9a66-d9bf64fca2ca/rules.new/cfengine-community/system_logrotate/1.1/rudder_reporting.cf:12:0: error: Conflicting arity in calling bundle log_rudder, expected 5 arguments, 4 given

Policy generation is not possible but problem should be fixed wuith this version
https://www.rudder-project.org/redmine/issues/12759

How can I fix this?


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #12634: .pyc file are not cleand up during postinstReleasedBenoît PECCATTEActions
Actions #1

Updated by Alexis Mousset almost 6 years ago

Could you check if the ncf-api-virtualenv package is in 4.3.2 too?

It may be https://www.rudder-project.org/redmine/issues/12634.
Could you send the output of "ls -l /usr/share/ncf/tools/*.pyc" to see if it really this one?
Then you can delete /usr/share/ncf/tools/*.pyc, restart the apache service and regenerat policies, it should fix this problem.

Actions #2

Updated by Tobias Ell almost 6 years ago

Hello Alexis,

installed packages are

ncf-4.3.2.release-1.EL.7.noarch
ncf-api-virtualenv-4.3.2.release-1.EL.7.noarch

rudder-jetty-4.3.2.release-1.EL.7.noarch
rudder-server-relay-4.3.2.release-1.EL.7.x86_64
rudder-reports-4.3.2.release-1.EL.7.noarch
rudder-agent-4.3.2.release-1.EL.7.x86_64
rudder-server-root-4.3.2.release-1.EL.7.noarch
rudder-techniques-4.3.2.release-1.EL.7.noarch
rudder-inventory-ldap-4.3.2.release-1.EL.7.x86_64
rudder-webapp-4.3.2.release-1.EL.7.noarch
rudder-inventory-endpoint-4.3.2.release-1.EL.7.noarch

output of ls l /usr/share/ncf/tools/*.pyc is
-rw-r--r-
2 root root 513 Jun 12 12:38 /usr/share/ncf/tools/get_promises.pyc
rw-r--r- 2 root root 4541 Jun 12 12:38 /usr/share/ncf/tools/ncf_constraints.pyc
rw-r--r- 2 root root 2411 Jun 12 12:38 /usr/share/ncf/tools/ncf_doc.pyc
rw-r--r- 2 root root 23471 Jun 12 12:38 /usr/share/ncf/tools/ncf.pyc
rw-r--r- 2 root root 9932 Jun 12 12:38 /usr/share/ncf/tools/ncf_rudder.pyc

shall I delete them?

Actions #3

Updated by Alexis Mousset almost 6 years ago

  • Category set to Packaging
  • Target version set to 4.3.3
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority changed from 0 to 52

Yes, you should remove all .pyc files and restart the apache2 service. https://www.rudder-project.org/redmine/issues/12634 should have fixed this.

Actions #4

Updated by Alexis Mousset almost 6 years ago

  • Related to Bug #12634: .pyc file are not cleand up during postinst added
Actions #5

Updated by Tobias Ell almost 6 years ago

Hello Alexis,

I am so sorry - while waiting for your answer I kept clicking around in the GUI and noticed several directives
with an orange arrow indicating deprecated versions. I migrated them and now policy generation works.
Maybe the upgrade documentation should include a hint to check for old directives.

Actions #6

Updated by Alexis Mousset almost 6 years ago

Did you remove the .pyc files before it worked?

Actions #7

Updated by Tobias Ell almost 6 years ago

Alexis,

I will remove the .pyc files as well - thanks

Actions #8

Updated by Tobias Ell almost 6 years ago

No - it already worked before I removed the files.
I only migrated the deprecated directives which seems to have help.

Actions #9

Updated by Alexis Mousset almost 6 years ago

Migrating the directives triggered a new policy generation, which probably worked then because post-install scripts and first agent run on the server had finished in the meantime.

Actions #10

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.3.3 to 4.3.4
Actions #11

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.3.4 to 4.3.5
Actions #12

Updated by François ARMAND over 5 years ago

  • Status changed from New to Rejected
  • Priority changed from 52 to 50

I propose to close that one since it seems to be non reproducible and (now) working.

Tobias, please reopened it if you encouter it again!

Actions

Also available in: Atom PDF