Project

General

Profile

Actions

Bug #14655

closed

When Rudder is shut down because there isn't enough free space, it's not easy to know WHY it was shut down

Added by Nicolas CHARLES about 5 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
N/A
Assignee:
-
Category:
Agent
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Very Small
Priority:
67
Name check:
Fix check:
Regression:

Description

Rudder shuts down if free space is lower than 2% on the Postgres or LDAP partition
During the archiving at night, it's possible to hit this limit - and so Rudder shuts down

If we don't look in the logs, there's no way to know why it was shut down, and why it restarts

It would be awesome if the agent or webapp could tell about this situation

Actions #1

Updated by François ARMAND about 5 years ago

  • Translation missing: en.field_tag_list set to community
  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Rudder settings | Plugins
  • Priority changed from 0 to 52

I set level to "no simple workaround" because from user point of view, it looks like Rudder is broken and it's extremelly difficult to know why.

Actions #2

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.10 to 5.0.11
Actions #3

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 5.0.11 to 5.0.12
  • Priority changed from 52 to 51
Actions #4

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.12 to 5.0.13
  • Priority changed from 51 to 50
Actions #5

Updated by Alexis Mousset almost 5 years ago

  • Category set to Agent
Actions #6

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
  • Priority changed from 50 to 49
Actions #7

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
  • Priority changed from 49 to 48
Actions #8

Updated by Benoît PECCATTE over 4 years ago

  • Priority changed from 48 to 47

It could be down in the 404/500 page since we don't shut down apache

Actions #9

Updated by François ARMAND over 4 years ago

  • Effort required set to Very Small
  • Priority changed from 47 to 73

The webapp could look at a file (flag), or it could check for space available at startup using the same value than the promise and stop with a big message. If rudder doesn't start, people will look at webapp logs. Also possible to set a special apache error message in that case.

Actions #10

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
  • Priority changed from 73 to 72
Actions #11

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
  • Priority changed from 72 to 69
Actions #12

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
  • Priority changed from 69 to 67
Actions #13

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #14

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #15

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #16

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #17

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #18

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #19

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #20

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #21

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #22

Updated by François ARMAND over 2 years ago

  • Status changed from New to Resolved

We added health check in the UI to help see that it will happen, and it does write a log when space is low. Closing it.

Actions

Also available in: Atom PDF