Project

General

Profile

Bug #3063

Apache 2 HTTP Server: No reporting on whether Apache 2 was started or not

Added by Nicolas CHARLES over 7 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
3
Category:
Techniques
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

There is currently no reports on the Apache technique to know if Apache2 was started as expected or not, and if it was restarted or not

We need a new component to resolve that


Related issues

Is duplicate of Rudder - Bug #3025: (ex PT/ Technique)Apache 2 HTTP Server: Incomplete/invalid reporting Released2012-11-22Actions
#1

Updated by Nicolas CHARLES over 7 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Nicolas CHARLES to Jonathan CLARKE
#2

Updated by Jonathan CLARKE over 7 years ago

  • Status changed from Pending technical review to Discussion
  • Assignee changed from Jonathan CLARKE to Nicolas CHARLES

Nicolas CHARLES wrote:

The pull request is here
https://github.com/Normation/rudder-techniques/pull/10

I'm bothered by this pull request because it introduces another change, which isn't just reporting: it changes the conditions for what "autostart" means. Do we start Apache immediately, or do we configure it to be started at boot? These are two separate settings.

If reporting needs fixing, please go ahead and make a pull request just for that, I will happily validate it.

However, this behaviour should not be changed without a clear warning, a Technique version change, and a clarification in the Technique's metadata. Maybe it is wrong in the first place? In this case, a bug should be filed against this problem - but it is clearly not a reporting bug as stated here.

#3

Updated by Nicolas CHARLES over 7 years ago

I can't fix the reporting without clarification on what should be done (or not done) if the service is started (or not), otherwise there are corner case when action are done without reporting, or not actin, but no reporting either

#4

Updated by Jonathan CLARKE over 7 years ago

Nicolas CHARLES wrote:

I can't fix the reporting without clarification on what should be done (or not done) if the service is started (or not), otherwise there are corner case when action are done without reporting, or not actin, but no reporting either

What should be done:
  • If the settings in a Directive request to set Apache to start on boot, it should be set to start on boot only, not necessarily started immediately.
  • If the settings in a Directive request to start/restart Apache after changing it's configuration, then this should be done immediately, regardless of the "start on boot" setting

Does anything else need clarifying?

#5

Updated by Nicolas CHARLES over 7 years ago

  • Assignee changed from Nicolas CHARLES to Jonathan CLARKE

Jonathan CLARKE wrote:

Nicolas CHARLES wrote:

I can't fix the reporting without clarification on what should be done (or not done) if the service is started (or not), otherwise there are corner case when action are done without reporting, or not actin, but no reporting either

What should be done:
  • If the settings in a Directive request to set Apache to start on boot, it should be set to start on boot only, not necessarily started immediately.
  • If the settings in a Directive request to start/restart Apache after changing it's configuration, then this should be done immediately, regardless of the "start on boot" setting

Does anything else need clarifying?

There is no setting in the PT/Technique to start/restart Apache after changing it's configuration; so I'm not sure I understand your explanation

#6

Updated by Jonathan CLARKE over 7 years ago

Nicolas CHARLES wrote:

Jonathan CLARKE wrote:

Nicolas CHARLES wrote:

I can't fix the reporting without clarification on what should be done (or not done) if the service is started (or not), otherwise there are corner case when action are done without reporting, or not actin, but no reporting either

What should be done:
  • If the settings in a Directive request to set Apache to start on boot, it should be set to start on boot only, not necessarily started immediately.
  • If the settings in a Directive request to start/restart Apache after changing it's configuration, then this should be done immediately, regardless of the "start on boot" setting

Does anything else need clarifying?

There is no setting in the PT/Technique to start/restart Apache after changing it's configuration; so I'm not sure I understand your explanation

I guess we should add one then.

#7

Updated by Jonathan CLARKE over 7 years ago

  • Assignee changed from Jonathan CLARKE to Nicolas CHARLES
#8

Updated by Matthieu CERDA over 7 years ago

  • Target version changed from 2.3.10 to 2.3.11
#9

Updated by Jonathan CLARKE over 7 years ago

  • Project changed from Rudder to Techniques
  • Category deleted (Techniques)
#10

Updated by Nicolas CHARLES over 7 years ago

Jonathan CLARKE wrote:

Nicolas CHARLES wrote:

Jonathan CLARKE wrote:

Nicolas CHARLES wrote:

I can't fix the reporting without clarification on what should be done (or not done) if the service is started (or not), otherwise there are corner case when action are done without reporting, or not actin, but no reporting either

What should be done:
  • If the settings in a Directive request to set Apache to start on boot, it should be set to start on boot only, not necessarily started immediately.
  • If the settings in a Directive request to start/restart Apache after changing it's configuration, then this should be done immediately, regardless of the "start on boot" setting

Does anything else need clarifying?

There is no setting in the PT/Technique to start/restart Apache after changing it's configuration; so I'm not sure I understand your explanation

I guess we should add one then.

So, it would be a new revision of the technique.
What about this one ?

#11

Updated by Nicolas CHARLES over 7 years ago

  • Assignee changed from Nicolas CHARLES to Jonathan CLARKE
#12

Updated by Matthieu CERDA about 7 years ago

  • Target version changed from 2.3.11 to 2.3.12
#13

Updated by Matthieu CERDA about 7 years ago

  • Target version changed from 2.3.12 to 2.3.13
#14

Updated by Nicolas PERRON about 7 years ago

  • Target version changed from 2.3.13 to 84
#15

Updated by Nicolas PERRON almost 7 years ago

  • Target version changed from 84 to 2.4.7
#16

Updated by Nicolas PERRON almost 7 years ago

  • Target version changed from 2.4.7 to 2.4.8
#17

Updated by Jonathan CLARKE almost 7 years ago

  • Assignee changed from Jonathan CLARKE to Nicolas CHARLES

Nicolas CHARLES wrote:

Jonathan CLARKE wrote:

Nicolas CHARLES wrote:

Jonathan CLARKE wrote:

Nicolas CHARLES wrote:

I can't fix the reporting without clarification on what should be done (or not done) if the service is started (or not), otherwise there are corner case when action are done without reporting, or not actin, but no reporting either

What should be done:
  • If the settings in a Directive request to set Apache to start on boot, it should be set to start on boot only, not necessarily started immediately.
  • If the settings in a Directive request to start/restart Apache after changing it's configuration, then this should be done immediately, regardless of the "start on boot" setting

Does anything else need clarifying?

There is no setting in the PT/Technique to start/restart Apache after changing it's configuration; so I'm not sure I understand your explanation

I guess we should add one then.

So, it would be a new revision of the technique.
What about this one ?

Sounds like the best approach, yes.

#18

Updated by Nicolas PERRON almost 7 years ago

  • Target version changed from 2.4.8 to 2.4.9
#19

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.9 to 2.4.10
#20

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.10 to 2.4.11
#21

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.11 to 2.4.12
#22

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.12 to 2.4.13
#23

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.4.13 to 2.6.11

Since Support for 2.4 branch is over, retargeting this issue to 2.6

#24

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.6.11 to 2.6.12
#25

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.6.12 to 2.6.13
#26

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.6.13 to 2.6.14
#27

Updated by Jonathan CLARKE almost 6 years ago

  • Target version changed from 2.6.14 to 2.6.16
#28

Updated by Jonathan CLARKE almost 6 years ago

  • Target version changed from 2.6.16 to 2.6.17
#29

Updated by Nicolas PERRON almost 6 years ago

  • Target version changed from 2.6.17 to 2.6.18
#30

Updated by Matthieu CERDA over 5 years ago

  • Target version changed from 2.6.18 to 2.6.19
#31

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.6.19 to 2.6.20
#32

Updated by François ARMAND over 5 years ago

  • Subject changed from (ex PT/ Technique)Apache 2 HTTP Server: No reporting on whether Apache 2 was started or not to Apache 2 HTTP Server: No reporting on whether Apache 2 was started or not
  • Target version changed from 2.6.20 to 2.10.10
#33

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.10.10 to 2.10.11
#34

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.10.11 to 2.10.12
#35

Updated by Benoît PECCATTE about 5 years ago

  • Project changed from Techniques to Rudder
  • Category set to Techniques
#36

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.12 to 2.10.13
#37

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.13 to 2.10.14
#38

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.14 to 2.10.15
#39

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.10.15 to 2.10.16
#40

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.10.16 to 2.10.17
#41

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.17 to 2.10.18
#42

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.18 to 2.10.19
#43

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.19 to 2.10.20
#44

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.20 to 2.11.18
#45

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.18 to 2.11.19
#46

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.19 to 2.11.20
#47

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.11.20 to 2.11.21
#48

Updated by Jonathan CLARKE about 4 years ago

  • Status changed from Discussion to Rejected

This was implemented in 2012, in #3025

#49

Updated by Jonathan CLARKE about 4 years ago

  • Related to deleted (Bug #3025: (ex PT/ Technique)Apache 2 HTTP Server: Incomplete/invalid reporting )
#50

Updated by Jonathan CLARKE about 4 years ago

  • Is duplicate of Bug #3025: (ex PT/ Technique)Apache 2 HTTP Server: Incomplete/invalid reporting added

Also available in: Atom PDF