Project

General

Profile

Actions

User story #4185

closed

Configurable columns in node list

Added by Dennis Cabooter over 10 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
N/A
Category:
Web - Nodes & inventories
UX impact:
Suggestion strength:
User visibility:
Effort required:
Name check:
Fix check:
Regression:

Description

It would be nice to have configurable columns in the node list. E.g. I would like to hide the "OS SP" column forever, since it not relevant for me.


Subtasks 1 (0 open1 closed)

User story #4184: Compliance details column in the nodes listRejectedActions

Related issues 1 (0 open1 closed)

Is duplicate of Rudder - User story #7967: Make fields of node list customizableReleasedFrançois ARMANDActions
Actions #1

Updated by Nicolas PERRON over 10 years ago

  • Assignee set to Vincent MEMBRÉ
  • Target version set to Ideas (not version specific)

Thanks for the idea. We are actually working on the subject so any idea is welcome.

Vincent, could you look into this ?

Actions #2

Updated by Dennis Cabooter over 10 years ago

Is this still going forward? For example I would like to hide the "OS SP" column, because it makes no sense with Linux. And for example I would like to add rudder-agent version, so I don't have to remember which nodes are updated and which are not. The columns could be configurable from the Administration tab.

Actions #3

Updated by François ARMAND over 10 years ago

I won't go in 2.10, but we didn't forget about it.

Actions #4

Updated by Dennis Cabooter over 9 years ago

Will it go into 2.11.4? ^^

Actions #5

Updated by Jonathan CLARKE over 9 years ago

Dennis Cabooter wrote:

Will it go into 2.11.4? ^^

Definitely not - 0.0.Z increment releases are bug fixes only, and this is clearly not a bug fix. Stability comes first :)

Rudder 3.0 will introduce a whole new interface, so it makes sense to build this on top of the new interface. I expect we could do it for 3.1.

Actions #6

Updated by Olivier Chédru over 9 years ago

I would like to be able to add the version of a specific installed package.

Actions #7

Updated by Benoît PECCATTE about 9 years ago

  • Category set to Web - Nodes & inventories
Actions #8

Updated by Nicolas CHARLES over 3 years ago

  • Status changed from New to Rejected
Actions #9

Updated by Nicolas CHARLES over 3 years ago

Actions

Also available in: Atom PDF