Project

General

Profile

Actions

Bug #5366

closed

Deleting a Technique from ncf-builder will not remove Technique from Rudder

Added by Nicolas PERRON about 8 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
2
Assignee:
-
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

Deleting a Technique from ncf-builder interface will remove the Technique from interface and from /var/rudder/configuration-repository/ncf/50_techniques but the generated Rudder-compliant technique located in /var/rudder/configuration-repository/techniques/ncf_techniques/ will still be there.

Removing them will lead to #5203 if Directives are based on them but we should warn or do whatever to not let the Techniques in Rudder after a deletion.


Related issues 2 (0 open2 closed)

Related to Rudder - Bug #5203: There is no way to remove a Directive based on a Technique that no longer existsReleasedVincent MEMBRÉActions
Is duplicate of Rudder - User story #5670: Auto add ncf Technique to Rudder techniquesReleasedFrançois ARMAND2014-11-24Actions
Actions #1

Updated by Nicolas PERRON about 8 years ago

  • Priority changed from N/A to 2
  • Target version set to 2.11.2
Actions #2

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.2 to 0.x
Actions #3

Updated by Jonathan CLARKE almost 8 years ago

  • Status changed from New to Rejected

This is being addressed in #5670.

Actions #4

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #5

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF