Project

General

Profile

Actions

User story #6289

closed

Rudder-update need to check for the PostgreSQL version

Added by Florian Heigl about 6 years ago. Updated about 6 years ago.

Status:
Released
Priority:
1
Assignee:
Matthieu CERDA
Category:
System integration
Target version:
Suggestion strength:
User visibility:
Effort required:

Description

I was asked to open a bug about this:

On SLES 11SP3 with the "Databases" upstream repository I had the choices of PostgreSQL 8.3 and 9.0.
Back on Rudder 2.x I had chosen 8.3 as it was the "default" PostgreSQL package.

Rudder 3 can't work with PostgreSQL 8.3 and should be very noisy about this.
The update script should disallow proceeding with a relevant message.

A note in the update manual / release notes would also be good because a pg_dumpall / initdb / restore cycle needs to be accounted for in terms of upgrade time.


Subtasks 2 (0 open2 closed)

User story #6295: Rudder-update need to check for the PostgreSQL version (rudder-upgrade)ReleasedBenoît PECCATTE2015-02-24Actions
User story #6296: Rudder-update need to check for the PostgreSQL version (Documentation)ReleasedBenoît PECCATTE2015-02-24Actions
Actions #1

Updated by Nicolas CHARLES about 6 years ago

  • Category set to System integration
  • Assignee set to Matthieu CERDA
  • Target version set to 3.0.2

Thank you Florian for this ticket, it is indeed relevant to be very noisy about it.

Assigning to Matthieu, our expert in this field

Actions #2

Updated by Matthieu CERDA about 6 years ago

  • Tracker changed from Bug to User story
  • Subject changed from Rudder-update should check postgresql version to Rudder-update need to check for the PostgreSQL version
  • Status changed from New to 14
  • Priority changed from N/A to 1
Actions #3

Updated by Matthieu CERDA about 6 years ago

  • Status changed from 14 to 12
Actions #4

Updated by Matthieu CERDA about 6 years ago

  • Status changed from 12 to Pending release
Actions #5

Updated by Vincent MEMBRÉ about 6 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 3.0.2 which was released today.

Actions

Also available in: Atom PDF