Project

General

Profile

Bug #9864

Bug #9854: Slow compliance computation in Rudder 4.0

getNodeStatusReports is called for each node, and is slow to compute PolicyMode Inconsistency

Added by Nicolas CHARLES almost 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
N/A
Category:
Performance and scalability
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

getNodeStatusReports is called for every nodes with new compliance, and it easily cost several seconds from a thousand of node

Issue is in computation of status, which iterate over all compliance, and is fairly expensive (even more with 9857 as it triggers actual compliance computation) - it represents 50 to 80% of the cost of this method


Related issues

Is duplicate of Rudder - Bug #9869: Compliance on all reports is always computed, even when not necessaryReleased

History

#1 Updated by Nicolas CHARLES almost 2 years ago

  • Status changed from New to In progress

#2 Updated by Nicolas CHARLES almost 2 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Nicolas CHARLES to Fran├žois ARMAND
  • Pull Request set to https://github.com/Normation/rudder/pull/1411

#3 Updated by Nicolas CHARLES almost 2 years ago

  • Status changed from Pending technical review to Rejected

Ticket #9869 fixed the root cause

#4 Updated by Nicolas CHARLES almost 2 years ago

  • Is duplicate of Bug #9869: Compliance on all reports is always computed, even when not necessary added

Also available in: Atom PDF