Project

General

Profile

Actions

Bug #12223

closed

Transient policy generation error at upgrade from 4.2 to 4.3

Added by Nicolas CHARLES over 6 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
N/A
Category:
System techniques
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

Error at polivcy generation after an upgrade from 4.2 to 4.3

The error disappear by itself after one (two?) runs.

stderr: '/var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:30:0: error: Duplicate definition of bundle log_rudder with type agent /var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:64:0: error: Duplicate definition of bundle _rudder_common_report with type agent /var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:100:0: error: Duplicate definition of bundle _rudder_common_reports_generic with type agent /var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:167:0: error: Duplicate definition of bundle _startExecution with type agent /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:30:0: error: Duplicate definition of bundle log_rudder with type agent /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:258:0: error: Duplicate definition of bundle _rudder_common_report with type agent /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:294:0: error: Duplicate definition of bundle _rudder_common_reports_generic with type agent /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:339:0: error: Duplicate definition of bundle _startExecution with type agent /var/rudder/ncf/common/20_cfe_basics/cfengine/files.cf:1208:0: error: Duplicate definition of body INI_section with type select_region /var/rudder/ncf/common/20_cfe_basics/cfengine/files.39p.cf:22:0: error: Duplicate definition of body INI_section with type select_region /var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:190:0: error: Duplicate definition of body _rudder_always_classes_persist with type classes /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:362:0: error: Duplicate definition of body _rudder_always_classes_persist with type classes ' ; Exit code=1 for hook: '/opt/rudder/etc/hooks.d/policy-generation-node-ready/10-cf-promise-check'. stdout: stderr: '/var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:30:0: error: Duplicate definition of bundle log_rudder with type agent /var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:64:0: error: Duplicate definition of bundle _rudder_common_report with type agent /var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:100:0: error: Duplicate definition of bundle _rudder_common_reports_generic with type agent /var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:167:0: error: Duplicate definition of bundle _startExecution with type agent /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:30:0: error: Duplicate definition of bundle log_rudder with type agent /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:258:0: error: Duplicate definition of bundle _rudder_common_report with type agent /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:294:0: error: Duplicate definition of bundle _rudder_common_reports_generic with type agent /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:339:0: error: Duplicate definition of bundle _startExecution with type agent /var/rudder/ncf/common/20_cfe_basics/cfengine/files.cf:1208:0: error: Duplicate definition of body INI_section with type select_region /var/rudder/ncf/common/20_cfe_basics/cfengine/files.39p.cf:22:0: error: Duplicate definition of body INI_section with type select_region /var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:190:0: error: Duplicate definition of body _rudder_always_classes_persist with type classes /var/rudder/ncf/common/30_generic_methods/log_rudder.cf:362:0: error: Duplicate definition of body _rudder_always_classes_persist with type classes '

Related issues 1 (0 open1 closed)

Related to Rudder - Architecture #9207: Transient policy error after upgrade, need to improve handling of policies update during server upgrade (rudder-upgrade vs. ncf vs. rudder-techniques)ResolvedActions
Actions #1

Updated by François ARMAND over 6 years ago

  • Translation missing: en.field_tag_list set to Blocking 4.3
Actions #2

Updated by Benoît PECCATTE over 6 years ago

  • Assignee set to Alexis Mousset
Actions #3

Updated by Alexis Mousset about 6 years ago

Reproduced:

 Policy update error for process '6' at 2018-03-30 09:08:50 
⇨ Cannot write configuration node 
⇨ Exit code=1 for hook: '/opt/rudder/etc/hooks.d/policy-generation-node-ready/10-cf-promise-check'.
stdout: 
stderr: '/var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:30:0: error: Duplicate definition of bundle log_rudder with type agent
/var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:64:0: error: Duplicate definition of bundle _rudder_common_report with type agent
/var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:100:0: error: Duplicate definition of bundle _rudder_common_reports_generic with type agent
/var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:167:0: error: Duplicate definition of bundle _startExecution with type agent
/var/rudder/ncf/common/30_generic_methods/log_rudder.cf:30:0: error: Duplicate definition of bundle log_rudder with type agent
/var/rudder/ncf/common/30_generic_methods/log_rudder.cf:258:0: error: Duplicate definition of bundle _rudder_common_report with type agent
/var/rudder/ncf/common/30_generic_methods/log_rudder.cf:294:0: error: Duplicate definition of bundle _rudder_common_reports_generic with type agent
/var/rudder/ncf/common/30_generic_methods/log_rudder.cf:339:0: error: Duplicate definition of bundle _startExecution with type agent
/var/rudder/ncf/common/20_cfe_basics/cfengine/files.cf:1208:0: error: Duplicate definition of body INI_section with type select_region
/var/rudder/ncf/common/20_cfe_basics/cfengine/files.39p.cf:22:0: error: Duplicate definition of body INI_section with type select_region
/var/rudder/ncf/common/20_cfe_basics/log_rudder.cf:190:0: error: Duplicate definition of body _rudder_always_classes_persist with type classes
/var/rudder/ncf/common/30_generic_methods/log_rudder.cf:362:0: error: Duplicate definition of body _rudder_always_classes_persist with type classes
'

Actions #4

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.0~rc2 to 4.3.0~rc3
Actions #5

Updated by Alexis Mousset about 6 years ago

This happens because we do a synchronization between /usr/share/ncf/tree and /var/rudder/ncf/common (with rsync) in the rudder-upgrade script, that is executing in postinst, so:

  • After the installation of the new ncf
  • Before the cleaning of the old package (and removal of files that have been removed or moved)

This leads to broken policies until the next agent run that synchronizes correct policies. This bug always existed and probably explains a part transient errors we saw (each time we moved or removed files in ncf).

Actions #6

Updated by Alexis Mousset about 6 years ago

  • Related to Architecture #9207: Transient policy error after upgrade, need to improve handling of policies update during server upgrade (rudder-upgrade vs. ncf vs. rudder-techniques) added
Actions #7

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.3.0~rc3 to 4.3.0
Actions #8

Updated by François ARMAND about 6 years ago

  • Translation missing: en.field_tag_list deleted (Blocking 4.3)
  • Target version changed from 4.3.0 to 4.1.11

For now, we don't have a good solution (each one we thought to seems to introduce a variation of that problem). This is not blocking for 4.3 (as it is transcient), and was already present in previous version (even if 4.3 make it happens more frequently since we removed ncf files).

I'm retargeting it to 4.1 and remove the blocking status.

Actions #9

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
Actions #10

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
Actions #11

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 4.1.13 to 411
Actions #12

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 411 to 4.1.13
Actions #13

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
Actions #14

Updated by François ARMAND almost 6 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority changed from 0 to 31
Actions #15

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
Actions #16

Updated by François ARMAND almost 6 years ago

  • Description updated (diff)
  • Priority changed from 31 to 30
Actions #17

Updated by Jonathan CLARKE almost 6 years ago

  • User visibility changed from Operational - other Techniques | Technique editor | Rudder settings to Getting started - demo | first install | level 1 Techniques
  • Priority changed from 30 to 47

Upgrading the user visibility on this because several first time users install one version then try to upgrade and hit this, leaving a bad first impression.

Actions #18

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
  • Priority changed from 47 to 46
Actions #19

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
  • Priority changed from 46 to 45
Actions #20

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
  • Priority changed from 45 to 0
Actions #21

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #22

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #23

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.1.20 to 4.1.21
Actions #24

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.21 to 4.1.22
Actions #25

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.22 to 4.1.23
Actions #26

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.23 to 4.1.24
Actions #27

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.1.24 to 588
Actions #28

Updated by Alexis Mousset almost 5 years ago

  • Status changed from New to Rejected

Closing this one as it is specific to 4.2->4.3, and #9207 track the root cause (which is mostly fixed by package merges in 5.1)

Actions #29

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 588 to 4.1.24
Actions

Also available in: Atom PDF