Project

General

Profile

Bug #4709

When a node is deleted, its generated promises are not removed

Added by Jonathan CLARKE over 4 years ago. Updated 17 days ago.

Status:
Released
Priority:
3
Category:
Web - Nodes & inventories
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

I just removed a node from Rudder by pressing the "Delete node" button in the interface, but it's promises are still on the disk. They should be removed.

Found in Rudder 2.10.0, but probably present in older versions too.


Related issues

Related to Rudder - Bug #5462: Relay servers keeps sending inventories of their managed nodes at every runReleased2014-09-02
Is duplicate of Rudder - Bug #9719: Node deletes are not properly cleaned upNew

Associated revisions

Revision d78d15b5 (diff)
Added by François ARMAND 30 days ago

Fixes #4709: When a node is deleted, its generated promises are not removed

History

#1 Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.6.13 to 2.6.14

#2 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.6.14 to 2.6.16

#3 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.6.16 to 2.6.17

#4 Updated by Nicolas PERRON over 4 years ago

  • Target version changed from 2.6.17 to 2.6.18

#5 Updated by Matthieu CERDA about 4 years ago

  • Target version changed from 2.6.18 to 2.6.19

#6 Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.6.19 to 2.6.20

#7 Updated by François ARMAND almost 4 years ago

  • Status changed from 8 to New
  • Assignee set to Nicolas CHARLES
  • Target version changed from 2.6.20 to 2.10.10

Nico, how do you think we should handle that ?

I see several solutions:
- trigger a rm rf ${nodeid} or something alike from rudder UI when a node is deleted;
on each promise generation, delete all unknown files in /var/rudder/share to keep only existing nodes,
- have a cfengine (sytem) promise making the cleaning for us

What do you think is best ?
The direct removal is über simple but not too convergent, the second solution add time to generation, the last may not scale to well with thousand of nodes... But still seem to be the best.

#8 Updated by Nicolas CHARLES almost 4 years ago

First or second solution should be the best
third one doesn't seem really relevant; passing to cfengine the list of all managed nodes is a bit risky

We also need to have a way to propagate this change to relay server

#9 Updated by François ARMAND almost 4 years ago

I don't understand why it's risky: it's exactly what is done for the autorization and promise transmission. And it will be a simple way to transfert that to relay node. Basically, it say: if you serve promises, you also have to ensure that no garbage is available around what is served, and clean it if needed.

Could you explain what scares you in that solution ?

#10 Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.10.10 to 2.10.11

#11 Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.10.11 to 2.10.12

#12 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.12 to 2.10.13

#13 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.13 to 2.10.14

#14 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.14 to 2.10.15

#15 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.15 to 2.10.16

#16 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.16 to 2.10.17

#17 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.17 to 2.10.18

#18 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.18 to 2.10.19

#19 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.19 to 2.10.20

#20 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.20 to 2.11.18

#21 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.11.18 to 2.11.19

#22 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.11.19 to 2.11.20

#23 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.20 to 2.11.21

#24 Updated by François ARMAND over 2 years ago

  • Related to Bug #7288: Policy does not get deleted when changing relays added

#25 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.21 to 2.11.22

#26 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.22 to 2.11.23

#27 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.23 to 2.11.24

#28 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.24 to 308

#29 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 308 to 3.1.14

#30 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.14 to 3.1.15

#31 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.15 to 3.1.16

#32 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.16 to 3.1.17

#33 Updated by Janos Mattyasovszky about 2 years ago

  • Related to Bug #9719: Node deletes are not properly cleaned up added

#34 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.17 to 3.1.18

#35 Updated by Janos Mattyasovszky about 2 years ago

Just FYI, our last policy generation was on Dec 8, 1PM.
  • 8593 folders are in /var/rudder/share for end-nodes:
  • 1912 folders are not from the latest polgen (decom'ed servers).
  • 6681 folders container the valid promises for the current nodes.

#36 Updated by François ARMAND almost 2 years ago

  • Status changed from New to In progress
  • Assignee changed from Nicolas CHARLES to François ARMAND

#37 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.18 to 3.1.19

#38 Updated by Benoît PECCATTE almost 2 years ago

  • Subject changed from When a node is deleted, it's generated promises are not removed to When a node is deleted, its generated promises are not removed
  • Status changed from In progress to Rejected

Duplicate of #9719

#39 Updated by François ARMAND over 1 year ago

  • Related to Bug #5154: Node key not deleted after deleting a node in the web ui added

#40 Updated by François ARMAND over 1 year ago

  • Related to deleted (Bug #5154: Node key not deleted after deleting a node in the web ui)

#41 Updated by François ARMAND over 1 year ago

  • Related to deleted (Bug #7288: Policy does not get deleted when changing relays)

#42 Updated by François ARMAND over 1 year ago

  • Related to deleted (Bug #9719: Node deletes are not properly cleaned up)

#43 Updated by François ARMAND over 1 year ago

  • Is duplicate of Bug #9719: Node deletes are not properly cleaned up added

#44 Updated by François ARMAND about 1 month ago

  • Status changed from Rejected to New
  • Target version changed from 3.1.19 to 4.1.17
  • Priority set to 0

It is not actually a duplicate of the referenced bug which just list other tickets.

#45 Updated by François ARMAND about 1 month ago

  • Status changed from New to Pending technical review
  • Assignee changed from François ARMAND to Benoît PECCATTE
  • Pull Request set to https://github.com/Normation/rudder/pull/2081

#46 Updated by François ARMAND 30 days ago

  • Assignee changed from Benoît PECCATTE to Nicolas CHARLES

#47 Updated by François ARMAND 30 days ago

  • Assignee changed from Nicolas CHARLES to Benoît PECCATTE

#48 Updated by François ARMAND 30 days ago

  • Status changed from Pending technical review to Pending release

#49 Updated by Vincent MEMBRÉ 17 days ago

  • Status changed from Pending release to Released
This bug has been fixed in Rudder 4.1.17, 4.3.7 and 5.0.3 which were released today.
Changelog
Changelog
Changelog

Also available in: Atom PDF